summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author klaatu2013-06-04 23:15:42 +0200
committer Robby Workman2013-06-05 10:17:44 +0200
commit328580f514324cbb23c5ed75509a134efe54efdb (patch)
tree0d19b13c85eb15f00414b74fd4a7d1da26707a4d /python
parenta72cc2c168bf1a76b4ce9603b696a0810bfee2de (diff)
downloadslackbuilds-328580f514324cbb23c5ed75509a134efe54efdb.tar.gz
python/python-daemon: Added (create pythonic daemon processes)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-daemon/README8
-rw-r--r--python/python-daemon/python-daemon.SlackBuild74
-rw-r--r--python/python-daemon/python-daemon.info10
-rw-r--r--python/python-daemon/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/python/python-daemon/README b/python/python-daemon/README
new file mode 100644
index 0000000000..e67a64ede3
--- /dev/null
+++ b/python/python-daemon/README
@@ -0,0 +1,8 @@
+This library implements the well-behaved daemon specification of PEP
+3143, "Standard daemon process library".
+
+A well-behaved Unix daemon process is tricky to get right, but the
+required steps are much the same for every daemon program. A
+DaemonContext instance holds the behaviour and configured process
+environment for the program; use the instance as a context manager to
+enter a daemon state.
diff --git a/python/python-daemon/python-daemon.SlackBuild b/python/python-daemon/python-daemon.SlackBuild
new file mode 100644
index 0000000000..f35c16c679
--- /dev/null
+++ b/python/python-daemon/python-daemon.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for python-daemon
+
+# Copyright 2013 klaatu at member.fsf.org
+#
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=python-daemon
+VERSION=${VERSION:-1.5.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO ChangeLog \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-daemon/python-daemon.info b/python/python-daemon/python-daemon.info
new file mode 100644
index 0000000000..bbac431169
--- /dev/null
+++ b/python/python-daemon/python-daemon.info
@@ -0,0 +1,10 @@
+PRGNAM="python-daemon"
+VERSION="1.5.5"
+HOMEPAGE="https://pypi.python.org/pypi/python-daemon/"
+DOWNLOAD="https://pypi.python.org/packages/source/p/python-daemon/python-daemon-1.5.5.tar.gz"
+MD5SUM="1f6cd41473c2e201021a0aeef395b2b1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="distribute"
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.nospam.fsf.org"
diff --git a/python/python-daemon/slack-desc b/python/python-daemon/slack-desc
new file mode 100644
index 0000000000..b2c20d6a6f
--- /dev/null
+++ b/python/python-daemon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-daemon: python-daemon (python library to create pythonic daemon processes)
+python-daemon:
+python-daemon: This library implements the well-behaved daemon specification of
+python-daemon: PEP 3143, "Standard daemon process library".
+python-daemon:
+python-daemon: A well-behaved Unix daemon process is tricky to get right, but
+python-daemon: the required steps are much the same for every daemon program. A
+python-daemon: DaemonContext instance holds the behaviour and configured process
+python-daemon: environment for the program; use the instance as a context manager
+python-daemon: to enter a daemon state.
+python-daemon: