summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Jeremy Hansen2023-10-03 09:55:00 +0200
committer Willy Sudiarto Raharjo2023-10-06 19:59:33 +0200
commit0efe933e68a129bbe2f266c4bf13e64ddea2d861 (patch)
tree55c9f54df30478a7ede050328d71d8625f8354e6 /python
parentfa68d3f9085eb8ed7f93280b06dc048a4c2bb16e (diff)
downloadslackbuilds-0efe933e68a129bbe2f266c4bf13e64ddea2d861.tar.gz
python/python3-platformdirs: Version bump to 3.11.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-platformdirs/python3-platformdirs.SlackBuild18
-rw-r--r--python/python3-platformdirs/python3-platformdirs.info8
2 files changed, 15 insertions, 11 deletions
diff --git a/python/python3-platformdirs/python3-platformdirs.SlackBuild b/python/python3-platformdirs/python3-platformdirs.SlackBuild
index 609092b7ca..43d87ca8e2 100644
--- a/python/python3-platformdirs/python3-platformdirs.SlackBuild
+++ b/python/python3-platformdirs/python3-platformdirs.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python3-platformdirs
# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-platformdirs
-VERSION=${VERSION:-2.5.1}
+VERSION=${VERSION:-3.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -50,16 +51,12 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -78,13 +75,20 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+# Fix version importing when using setuptools_scm<7
+# Thanks to dofuuz
+# https://github.com/dofuuz/python-soxr/issues/21
+sed -i 's/version =/__version__ = &/' $PKG/usr/lib$LIBDIRSUFFIX/python3.9/site-packages/$SRCNAM/version.py
+sed -i 's/version_tuple/__&__ = &/' $PKG/usr/lib$LIBDIRSUFFIX/python3.9/site-packages/$SRCNAM/version.py
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-platformdirs/python3-platformdirs.info b/python/python3-platformdirs/python3-platformdirs.info
index 532bfed4b7..95b0e91683 100644
--- a/python/python3-platformdirs/python3-platformdirs.info
+++ b/python/python3-platformdirs/python3-platformdirs.info
@@ -1,10 +1,10 @@
PRGNAM="python3-platformdirs"
-VERSION="2.5.1"
+VERSION="3.11.0"
HOMEPAGE="https://github.com/platformdirs/platformdirs"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/platformdirs/platformdirs-2.5.1.tar.gz"
-MD5SUM="83d3ce3feb4af1ccfaca24375574f44d"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/platformdirs/platformdirs-3.11.0.tar.gz"
+MD5SUM="a6ba3a442347fac346982acb597c8bf8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build python3-hatch_vcs"
MAINTAINER="Jeremy Hansen"
EMAIL="jebrhansen+SBo@gmail.com"