summaryrefslogtreecommitdiffstats
path: root/python/sympy
diff options
context:
space:
mode:
author Serban Udrea2022-10-14 20:37:09 +0200
committer Willy Sudiarto Raharjo2022-10-15 05:47:38 +0200
commit946c71f7577d4b4e0832b1b9e3d7489b6bf9a0e6 (patch)
tree85b5a0f5c104f150f9da2fce1f9735111634ca80 /python/sympy
parent28c5f86cc906edce79ceaacc6fad1270f30981b4 (diff)
downloadslackbuilds-946c71f7577d4b4e0832b1b9e3d7489b6bf9a0e6.tar.gz
python/sympy: Removed (renamed python/python2-sympy).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/sympy')
-rw-r--r--python/sympy/README9
-rw-r--r--python/sympy/slack-desc19
-rw-r--r--python/sympy/sympy.SlackBuild91
-rw-r--r--python/sympy/sympy.info10
4 files changed, 0 insertions, 129 deletions
diff --git a/python/sympy/README b/python/sympy/README
deleted file mode 100644
index 514b9f2f2b..0000000000
--- a/python/sympy/README
+++ /dev/null
@@ -1,9 +0,0 @@
-SymPy is a Python library for symbolic mathematics. It aims to become
-a full-featured computer algebra system (CAS) while keeping the
-code as simple as possible in order to be comprehensible and easily
-extensible. SymPy is written entirely in Python and does not require
-any external libraries.
-
-SymPy has several optional dependencies which enhance its functionality
-or make it faster. Here are those available at SlackBuilds.org:
-numpy, scipy, matplotlib, ipython and pyglet.
diff --git a/python/sympy/slack-desc b/python/sympy/slack-desc
deleted file mode 100644
index 8901d657c0..0000000000
--- a/python/sympy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-sympy: sympy (Python library for symbolic mathematics)
-sympy:
-sympy: SymPy aims to become a full-featured computer algebra system (CAS)
-sympy: while keeping the code as simple as possible in order to be
-sympy: comprehensible and easily extensible. SymPy is written entirely in
-sympy: Python and does not require any external libraries.
-sympy:
-sympy: Homepage: https://sympy.org
-sympy:
-sympy:
-sympy:
diff --git a/python/sympy/sympy.SlackBuild b/python/sympy/sympy.SlackBuild
deleted file mode 100644
index f56f9b9122..0000000000
--- a/python/sympy/sympy.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for sympy
-
-# Copyright 2019 Serban Udrea <s.udrea@gsi.de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification,
-# is permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
-# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
-# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
-
-# Written by Grissiom <chaos.proton@gmail.com>
-# Updated for 0.6.7 by João Felipe Santos <joao.eel@gmail.com>
-# Updated for 0.7.3 and 0.7.6 by Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-# Updated for 0.7.1, 0.7.5 and 1.3 by Serban Udrea <S.Udrea@gsi.de>
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=sympy
-VERSION=${VERSION:-1.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mv $PKG/usr/share/man $PKG/usr/man
-rmdir $PKG/usr/share
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS LICENSE PKG-INFO README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/sympy/sympy.info b/python/sympy/sympy.info
deleted file mode 100644
index c093e66712..0000000000
--- a/python/sympy/sympy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="sympy"
-VERSION="1.3"
-HOMEPAGE="https://sympy.org"
-DOWNLOAD="https://github.com/sympy/sympy/releases/download/sympy-1.3/sympy-1.3.tar.gz"
-MD5SUM="11e18423f52e248108a3bd4307185bc1"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-mpmath"
-MAINTAINER="Serban Udrea"
-EMAIL="S.Udrea@gsi.de"