summaryrefslogtreecommitdiffstats
path: root/python/python3-pandas
diff options
context:
space:
mode:
author fourtysixandtwo2023-10-05 22:54:29 +0200
committer Willy Sudiarto Raharjo2023-10-07 10:58:37 +0200
commitc08367b9483d79972e2ec2d9fd472aa75124caae (patch)
treee72d6a573a4a7ac237e1dd8c2de02f73b889924b /python/python3-pandas
parent91beb7a9b24783b4842ad304d2768c34357dea48 (diff)
downloadslackbuilds-c08367b9483d79972e2ec2d9fd472aa75124caae.tar.gz
python/python3-pandas: Updated for version 2.1.1.
updating with Jeremy's permission Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-pandas')
-rw-r--r--python/python3-pandas/python3-pandas.SlackBuild18
-rw-r--r--python/python3-pandas/python3-pandas.info8
2 files changed, 19 insertions, 7 deletions
diff --git a/python/python3-pandas/python3-pandas.SlackBuild b/python/python3-pandas/python3-pandas.SlackBuild
index df9305bf70..480c33e84f 100644
--- a/python/python3-pandas/python3-pandas.SlackBuild
+++ b/python/python3-pandas/python3-pandas.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pandas
SRCNAM=pandas
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-2.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,14 +65,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# remove requirement
+sed -i '/oldest-supported-numpy/d' pyproject.toml
+
+# convert to minimum req'd instead of pinned
+sed -i 's/meson-python==/meson-python>=/' pyproject.toml
+sed -i 's/meson==/meson>=/' pyproject.toml
+
+# needs newer meson
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+# cannot build sdist, specify just wheel
+python3 -m build --wheel --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE PKG-INFO README.md RELEASE.md \
+ AUTHORS.md LICENSE PKG-INFO README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python3-pandas/python3-pandas.info b/python/python3-pandas/python3-pandas.info
index d37f42d89d..125868501e 100644
--- a/python/python3-pandas/python3-pandas.info
+++ b/python/python3-pandas/python3-pandas.info
@@ -1,10 +1,10 @@
PRGNAM="python3-pandas"
-VERSION="1.4.2"
+VERSION="2.1.1"
HOMEPAGE="https://pandas.pydata.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pandas/pandas-1.4.2.tar.gz"
-MD5SUM="6e007c8e950c280f7ac31cfaec8ab361"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pandas/pandas-2.1.1.tar.gz"
+MD5SUM="922757466055068bddebd57bf443f2ed"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-numpy python3-dateutil pytz"
+REQUIRES="python3-build python3-wheel python3-numpy python3-dateutil pytz tzdata python3-versioneer python3-mesonpy"
MAINTAINER="Jeremy Hansen"
EMAIL="jebrhansen+SBo@gmail.com"