summaryrefslogtreecommitdiffstats
path: root/python/python3-deprecated
diff options
context:
space:
mode:
author Jeremy Hansen2023-06-17 03:57:31 +0200
committer Willy Sudiarto Raharjo2023-06-17 03:57:31 +0200
commite1e89838c811bdb4e300df909384de2c93d0561a (patch)
tree54a94202d4663ce2ef3eb3f266e73575d21d9884 /python/python3-deprecated
parent03d862a3e9583b9b7ac92feb814bcb6068eb004f (diff)
downloadslackbuilds-e1e89838c811bdb4e300df909384de2c93d0561a.tar.gz
python/python3-deprecated: Added (deprecated decorators).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-deprecated')
-rw-r--r--python/python3-deprecated/README4
-rw-r--r--python/python3-deprecated/python3-deprecated.SlackBuild80
-rw-r--r--python/python3-deprecated/python3-deprecated.info10
-rw-r--r--python/python3-deprecated/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/python/python3-deprecated/README b/python/python3-deprecated/README
new file mode 100644
index 0000000000..7d042c558e
--- /dev/null
+++ b/python/python3-deprecated/README
@@ -0,0 +1,4 @@
+python3-deprecated (eprecate old python classes, functions or method)
+
+Python @deprecated decorator to deprecate old python classes,
+functions or methods.
diff --git a/python/python3-deprecated/python3-deprecated.SlackBuild b/python/python3-deprecated/python3-deprecated.SlackBuild
new file mode 100644
index 0000000000..eb2623a93c
--- /dev/null
+++ b/python/python3-deprecated/python3-deprecated.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/bash
+
+# Slackware build script for python3-deprecated
+
+# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-deprecated
+VERSION=${VERSION:-1.2.14}
+SRCNAM=${SRCNAM:-deprecated}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.rst LICENSE.rst README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-deprecated/python3-deprecated.info b/python/python3-deprecated/python3-deprecated.info
new file mode 100644
index 0000000000..1e451e9514
--- /dev/null
+++ b/python/python3-deprecated/python3-deprecated.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-deprecated"
+VERSION="1.2.14"
+HOMEPAGE="https://github.com/tantale/deprecated"
+DOWNLOAD="https://github.com/tantale/deprecated/archive/refs/tags/v1.2.14/deprecated-1.2.14.tar.gz"
+MD5SUM="f7f57b4087b358680c24680ac3944554"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-wrapt"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-deprecated/slack-desc b/python/python3-deprecated/slack-desc
new file mode 100644
index 0000000000..5f27cf97e3
--- /dev/null
+++ b/python/python3-deprecated/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-deprecated: python3-deprecated (Deprecate old classes, functions or methods)
+python3-deprecated:
+python3-deprecated: Python @deprecated decorator to deprecate old python classes,
+python3-deprecated: functions or methods.
+python3-deprecated:
+python3-deprecated: HOMEPAGE: https://github.com/tantale/deprecated
+python3-deprecated:
+python3-deprecated:
+python3-deprecated:
+python3-deprecated:
+python3-deprecated: