summaryrefslogtreecommitdiffstats
path: root/python/python3-astroid
diff options
context:
space:
mode:
author Markus Rinne2018-08-17 23:28:57 +0200
committer Willy Sudiarto Raharjo2018-08-18 03:39:48 +0200
commit1a61a66fb590f1dcfa7500e8cd60e37ab3781f80 (patch)
treeae102c479a5457c2b4ffa0730593d0591e0191ba /python/python3-astroid
parentf8fedf42567e61c7d77f4de1bd2508bc11e29d2e (diff)
downloadslackbuilds-1a61a66fb590f1dcfa7500e8cd60e37ab3781f80.tar.gz
python/python3-astroid: Added (new abstract syntax tree).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/python3-astroid')
-rw-r--r--python/python3-astroid/README12
-rw-r--r--python/python3-astroid/python3-astroid.SlackBuild88
-rw-r--r--python/python3-astroid/python3-astroid.info10
-rw-r--r--python/python3-astroid/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/python/python3-astroid/README b/python/python3-astroid/README
new file mode 100644
index 0000000000..ddfdb8c032
--- /dev/null
+++ b/python/python3-astroid/README
@@ -0,0 +1,12 @@
+The aim of this module is to provide a common base representation of
+python source code for projects such as pychecker, pyreverse,
+pylint... Well, actually the development of this library is essentially
+governed by pylint's needs. It used to be called logilab-astng.
+
+It provides a compatible representation which comes from the `_ast`
+module. It rebuilds the tree generated by the builtin _ast module by
+recursively walking down the AST and building an extended ast. The new
+node classes have additional methods and attributes for different
+usages. They include some support for static inference and local name
+scopes. Furthermore, astroid builds partial trees by inspecting living
+objects.
diff --git a/python/python3-astroid/python3-astroid.SlackBuild b/python/python3-astroid/python3-astroid.SlackBuild
new file mode 100644
index 0000000000..9bbb8bf98e
--- /dev/null
+++ b/python/python3-astroid/python3-astroid.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for python3-astroid
+
+# Copyright 2018 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-astroid
+SRCNAM=astroid
+VERSION=${VERSION:-2.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README* COPYING* ChangeLog PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-astroid/python3-astroid.info b/python/python3-astroid/python3-astroid.info
new file mode 100644
index 0000000000..212552c9c1
--- /dev/null
+++ b/python/python3-astroid/python3-astroid.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-astroid"
+VERSION="2.0.4"
+HOMEPAGE="https://bitbucket.org/logilab/astroid"
+DOWNLOAD="https://files.pythonhosted.org/packages/73/5f/560f729a496a27b658687d90ece2865c9b8ba60f28f7460f5ebf2acf8c4f/astroid-2.0.4.tar.gz"
+MD5SUM="eb1c4312019809696634b33d639eee9d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pytest-runner python3-lazy-object-proxy python3-six python3-wrapt typed_ast"
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"
diff --git a/python/python3-astroid/slack-desc b/python/python3-astroid/slack-desc
new file mode 100644
index 0000000000..1d59e3f06a
--- /dev/null
+++ b/python/python3-astroid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-astroid: python3-astroid (new abstract syntax tree from Python's ast)
+python3-astroid:
+python3-astroid: The aim of this module is to provide a common base representation
+python3-astroid: of python source code for projects such as pychecker, pyreverse,
+python3-astroid: pylint... Well, actually the development of this library is
+python3-astroid: essentially governed by pylint's needs. It used to be called
+python3-astroid: logilab-astng.
+python3-astroid:
+python3-astroid:
+python3-astroid: Homepage: https://github.com/PyCQA/astroid
+python3-astroid: