summaryrefslogtreecommitdiffstats
path: root/python/python3-Flask-Babel
diff options
context:
space:
mode:
author fourtysixandtwo2023-01-22 20:08:43 +0100
committer Willy Sudiarto Raharjo2023-01-28 02:22:49 +0100
commit87ad1718697ee44e6477c29fda5c78130b72ace5 (patch)
tree5f5fea4783435af84cf90c2f4f5271b6b8685bcc /python/python3-Flask-Babel
parentbeb91b70cf6312cc433ccb1439489329a447af71 (diff)
downloadslackbuilds-87ad1718697ee44e6477c29fda5c78130b72ace5.tar.gz
python/python3-Flask-Babel: Updated for version 3.0.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-Flask-Babel')
-rw-r--r--python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild20
-rw-r--r--python/python3-Flask-Babel/python3-Flask-Babel.info8
2 files changed, 14 insertions, 14 deletions
diff --git a/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild b/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild
index d9502d8ce8..b981f78ff3 100644
--- a/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild
+++ b/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-Babel
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,12 +24,14 @@
# 20220512 46and2: Updated version to v2.0.0
# -REQUIRES changed from babel to python3-babel
+# 20230122 46and2: Updated version, change build process, add deps.
+# -source archive filename changed
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-Babel
-SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-2.0.0}
+SRCNAM=$(echo ${PRGNAM,,} | sed -e "s/python3-//" -e 's/-/_/')
+VERSION=${VERSION:-3.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,17 +78,18 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-Flask-Babel/python3-Flask-Babel.info b/python/python3-Flask-Babel/python3-Flask-Babel.info
index 4ee66fee49..55671d79ac 100644
--- a/python/python3-Flask-Babel/python3-Flask-Babel.info
+++ b/python/python3-Flask-Babel/python3-Flask-Babel.info
@@ -1,10 +1,10 @@
PRGNAM="python3-Flask-Babel"
-VERSION="2.0.0"
+VERSION="3.0.0"
HOMEPAGE="https://github.com/python-babel/flask-babel"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-babel/Flask-Babel-2.0.0.tar.gz"
-MD5SUM="50d5e92d96ef58787bf85b5a1b0a5567"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-babel/flask_babel-3.0.0.tar.gz"
+MD5SUM="6da3763901e11e801de2d9f732062a13"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Flask python3-babel"
+REQUIRES="python3-poetry-core Flask python3-babel"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"