summaryrefslogtreecommitdiffstats
path: root/python/python-rubymarshal
diff options
context:
space:
mode:
author David Spencer2017-05-29 17:32:01 +0200
committer Willy Sudiarto Raharjo2017-06-03 02:59:38 +0200
commitf4871d1aed663954ca750b71a4d4ebaeb2213dc2 (patch)
treedc825a09746114f983e93d7139402308934c127e /python/python-rubymarshal
parent77d05abac02bc237e2dc51af3fcf09cd6596b3dc (diff)
downloadslackbuilds-f4871d1aed663954ca750b71a4d4ebaeb2213dc2.tar.gz
python/python-rubymarshal: Added (read/write Ruby-marshalled data).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-rubymarshal')
-rw-r--r--python/python-rubymarshal/README5
-rw-r--r--python/python-rubymarshal/python-rubymarshal.SlackBuild92
-rw-r--r--python/python-rubymarshal/python-rubymarshal.info10
-rw-r--r--python/python-rubymarshal/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python-rubymarshal/README b/python/python-rubymarshal/README
new file mode 100644
index 0000000000..a34d06e3a5
--- /dev/null
+++ b/python/python-rubymarshal/README
@@ -0,0 +1,5 @@
+python-rubymarshal (read and write Ruby-marshalled data)
+
+Only basic Ruby data types can be read and written.
+
+Optional dependency: python3
diff --git a/python/python-rubymarshal/python-rubymarshal.SlackBuild b/python/python-rubymarshal/python-rubymarshal.SlackBuild
new file mode 100644
index 0000000000..0b4c851493
--- /dev/null
+++ b/python/python-rubymarshal/python-rubymarshal.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python-rubymarshal
+
+# Copyright 2017 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-rubymarshal
+VERSION=${VERSION:-1.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-rubymarshal/python-rubymarshal.info b/python/python-rubymarshal/python-rubymarshal.info
new file mode 100644
index 0000000000..cc47f27981
--- /dev/null
+++ b/python/python-rubymarshal/python-rubymarshal.info
@@ -0,0 +1,10 @@
+PRGNAM="python-rubymarshal"
+VERSION="1.0.3"
+HOMEPAGE="https://pypi.python.org/pypi/python-rubymarshal"
+DOWNLOAD="https://pypi.python.org/packages/c9/92/b45f487d81d5d7e56a37ad85b9e903a5165a8c33ab952fd0235b5e7fc35c/rubymarshal-1.0.3.tar.gz"
+MD5SUM="df3c6b114637993adc5d3941c941f0d3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/python-rubymarshal/slack-desc b/python/python-rubymarshal/slack-desc
new file mode 100644
index 0000000000..662599d3e7
--- /dev/null
+++ b/python/python-rubymarshal/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-rubymarshal: python-rubymarshal (read and write Ruby-marshalled data)
+python-rubymarshal:
+python-rubymarshal: Read and write Ruby-marshalled data. Only basic Ruby data types can
+python-rubymarshal: be read and written.
+python-rubymarshal:
+python-rubymarshal: https://pypi.python.org/pypi/python-rubymarshal
+python-rubymarshal:
+python-rubymarshal:
+python-rubymarshal:
+python-rubymarshal:
+python-rubymarshal: