summaryrefslogtreecommitdiffstats
path: root/python/python-mccabe
diff options
context:
space:
mode:
author Dave Woodfall2021-05-14 22:34:39 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:01 +0200
commitea547454a0afca77834c74a1e460cea1f41b45a3 (patch)
tree1db8f20da2637ab4e7c52fc615ce6cb8e62e36c3 /python/python-mccabe
parent22a820478e9338a29ffe8f0d59b58f93a377a41b (diff)
downloadslackbuilds-ea547454a0afca77834c74a1e460cea1f41b45a3.tar.gz
python/python-mccabe: Renamed python2-mccabe.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-mccabe')
-rw-r--r--python/python-mccabe/README3
-rw-r--r--python/python-mccabe/python-mccabe.SlackBuild86
-rw-r--r--python/python-mccabe/python-mccabe.info10
-rw-r--r--python/python-mccabe/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/python-mccabe/README b/python/python-mccabe/README
deleted file mode 100644
index d462b9b785..0000000000
--- a/python/python-mccabe/README
+++ /dev/null
@@ -1,3 +0,0 @@
-McCabe checker, plugin for flake8. Ned's script to
-check McCabe complexity. This module provides a plugin
-for flake8, the Python code checker.
diff --git a/python/python-mccabe/python-mccabe.SlackBuild b/python/python-mccabe/python-mccabe.SlackBuild
deleted file mode 100644
index 2ab794de47..0000000000
--- a/python/python-mccabe/python-mccabe.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-mccabe
-
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-mccabe
-SRCNAM=$(echo $PRGNAM | cut -c8-13)
-VERSION=${VERSION:-0.6.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-mccabe/python-mccabe.info b/python/python-mccabe/python-mccabe.info
deleted file mode 100644
index 43eeec8629..0000000000
--- a/python/python-mccabe/python-mccabe.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-mccabe"
-VERSION="0.6.1"
-HOMEPAGE="https://github.com/flintwork/mccabe"
-DOWNLOAD="https://pypi.python.org/packages/06/18/fa675aa501e11d6d6ca0ae73a101b2f3571a565e0f7d38e062eec18a91ee/mccabe-0.6.1.tar.gz"
-MD5SUM="723df2f7b1737b8887475bac4c763e1e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pytest-runner"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-mccabe/slack-desc b/python/python-mccabe/slack-desc
deleted file mode 100644
index b83d5f770c..0000000000
--- a/python/python-mccabe/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-mccabe: python-mccabe (Complexity checker for Python)
-python-mccabe:
-python-mccabe: McCabe checker, plugin for flake8. Ned's script to check McCabe
-python-mccabe: complexity. This module provides a plugin for flake8, the Python
-python-mccabe: code checker.
-python-mccabe:
-python-mccabe: Homepage: https://github.com/flintwork/mccabe
-python-mccabe:
-python-mccabe:
-python-mccabe:
-python-mccabe: