summaryrefslogtreecommitdiffstats
path: root/python/python-esmre
diff options
context:
space:
mode:
author Dave Woodfall2021-05-03 07:50:14 +0200
committer Robby Workman2021-05-03 08:49:57 +0200
commit1703d6ef845afeb1cc921e7062541502a624ccaf (patch)
treeb8a825532103f1c1efa686be9bdd6aeb1b453ba5 /python/python-esmre
parentcd9dfdc586c9b1d35c5e9b2990febfc13dae4880 (diff)
downloadslackbuilds-1703d6ef845afeb1cc921e7062541502a624ccaf.tar.gz
python/python-esmre: Renamed python2-esmre.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python-esmre')
-rw-r--r--python/python-esmre/README2
-rw-r--r--python/python-esmre/python-esmre.SlackBuild86
-rw-r--r--python/python-esmre/python-esmre.info10
-rw-r--r--python/python-esmre/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/python/python-esmre/README b/python/python-esmre/README
deleted file mode 100644
index 354017ebc2..0000000000
--- a/python/python-esmre/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Modules used to accelerate execution of a large collection of regular
-expressions using the Aho-Corasick algorithms.
diff --git a/python/python-esmre/python-esmre.SlackBuild b/python/python-esmre/python-esmre.SlackBuild
deleted file mode 100644
index a59154f258..0000000000
--- a/python/python-esmre/python-esmre.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-esmre
-
-# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-esmre
-SRCNAM=esmre
-VERSION=${VERSION:-0.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING INSTALL PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-esmre/python-esmre.info b/python/python-esmre/python-esmre.info
deleted file mode 100644
index f020a3071b..0000000000
--- a/python/python-esmre/python-esmre.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-esmre"
-VERSION="0.3.1"
-HOMEPAGE="https://pypi.python.org/pypi/esmre/0.3.1"
-DOWNLOAD="https://pypi.python.org/packages/source/e/esmre/esmre-0.3.1.tar.gz"
-MD5SUM="95ace12bac0c79cf95712336489bc4a4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
diff --git a/python/python-esmre/slack-desc b/python/python-esmre/slack-desc
deleted file mode 100644
index 6acfc44460..0000000000
--- a/python/python-esmre/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-esmre: python-esmre (Regular expression accelerator)
-python-esmre:
-python-esmre: Modules used to accelerate execution of a large collection
-python-esmre: of regular expressions using the Aho-Corasick algorithms.
-python-esmre:
-python-esmre: Home page: https://code.google.com/p/esmre/
-python-esmre:
-python-esmre:
-python-esmre:
-python-esmre:
-python-esmre: