summaryrefslogtreecommitdiffstats
path: root/python/pyresample
diff options
context:
space:
mode:
author Dimitris Zlatanidis2023-11-30 11:48:53 +0100
committer Willy Sudiarto Raharjo2023-12-02 01:54:23 +0100
commit54560ae2dddb0b3453323f8c702d7229e9abdfe9 (patch)
treef5ceb585416620ac9933e3eee540aef6e011e5b1 /python/pyresample
parente9d6c35d4cc1e33a224e38b643ccd9ab95911390 (diff)
downloadslackbuilds-54560ae2dddb0b3453323f8c702d7229e9abdfe9.tar.gz
python/pyresample: Removed (unmaintained).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyresample')
-rw-r--r--python/pyresample/README11
-rw-r--r--python/pyresample/pyresample.SlackBuild92
-rw-r--r--python/pyresample/pyresample.info10
-rw-r--r--python/pyresample/slack-desc19
4 files changed, 0 insertions, 132 deletions
diff --git a/python/pyresample/README b/python/pyresample/README
deleted file mode 100644
index f7c5cd1ce5..0000000000
--- a/python/pyresample/README
+++ /dev/null
@@ -1,11 +0,0 @@
-Resampling (reprojection) of geospatial image data in Python.
-
-Pyresample uses a kd-tree approach for resampling.
-Pyresample is designed for resampling of remote sensing data
-and supports resampling from both fixed grids and geolocated
-swath data.
-
-Optional dependencies: numexpr, quicklook (not available from SBo)
-
-NOTE: Cython will not be used by default. Set environment variable
-'USE_CYTHON=True' to use it.
diff --git a/python/pyresample/pyresample.SlackBuild b/python/pyresample/pyresample.SlackBuild
deleted file mode 100644
index b2e6448473..0000000000
--- a/python/pyresample/pyresample.SlackBuild
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pyresample
-
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20230626 bkw: Modified by SlackBuilds.org, BUILD=2:
-# - don't install README in doc dir (it's a broken symlink).
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pyresample
-VERSION=${VERSION:-1.5.0}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+ || true
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt PKG-INFO docs/source/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pyresample/pyresample.info b/python/pyresample/pyresample.info
deleted file mode 100644
index 457872e672..0000000000
--- a/python/pyresample/pyresample.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyresample"
-VERSION="1.5.0"
-HOMEPAGE="https://github.com/pytroll/pyresample"
-DOWNLOAD="https://pypi.python.org/packages/8c/63/16cc107ef749ec2ef45dad6de83315f7f68e0418f1037d672375b2b36ab5/pyresample-1.5.0.tar.gz"
-MD5SUM="a3e9d559600845a9ac2c99841bfad6c4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-pyproj pykdtree configobj"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pyresample/slack-desc b/python/pyresample/slack-desc
deleted file mode 100644
index 8991a828e4..0000000000
--- a/python/pyresample/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyresample: pyresample (geospatial resampling)
-pyresample:
-pyresample: Resampling (reprojection) of geospatial image data in Python.
-pyresample: Pyresample uses a kd-tree approach for resampling. Pyresample is
-pyresample: designed for resampling of remote sensing data and supports
-pyresample: from both fixed grids and geolocated swath data.
-pyresample:
-pyresample: Homepage: https://github.com/pytroll/pyresample
-pyresample:
-pyresample:
-pyresample: