summaryrefslogtreecommitdiffstats
path: root/python/pycxx
diff options
context:
space:
mode:
author B. Watson2022-03-14 16:09:20 +0100
committer B. Watson2022-03-17 17:37:56 +0100
commit449a4cec59ca569e102c15d570dea62292c06016 (patch)
tree11a8d620b6718608a0c334d35e59fdced0ec0363 /python/pycxx
parent8dc2c6fe2bdc797b79a0a4610409225f2d8b8bf4 (diff)
downloadslackbuilds-449a4cec59ca569e102c15d570dea62292c06016.tar.gz
python/pycxx: Wrap README at 72 columns.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'python/pycxx')
-rw-r--r--python/pycxx/README45
1 files changed, 24 insertions, 21 deletions
diff --git a/python/pycxx/README b/python/pycxx/README
index a51cf9848d..7cc8f47993 100644
--- a/python/pycxx/README
+++ b/python/pycxx/README
@@ -1,27 +1,30 @@
PyCXX is designed to make it easier to extend Python with C++
-CXX/Objects is a set of C++ facilities to make it easier to write Python
-extensions. The chief way in which PyCXX makes it easier to write Python
-extensions is that it greatly increases the probability that your program
-will not make a reference-counting error and will not have to continually
-check error returns from the Python C API. CXX/Objects integrates Python
-with C++ in these ways:
- + C++ exception handling is relied on to detect errors and clean up. In a
- complicated function this is often a tremendous problem when writing in C.
- With PyCXX, we let the compiler keep track of what objects need to be
- dereferenced when an error occurs.
- + The Standard Template Library (STL) and its many algorithms plug and
+CXX/Objects is a set of C++ facilities to make it easier to write
+Python extensions. The chief way in which PyCXX makes it easier to
+write Python extensions is that it greatly increases the probability
+that your program will not make a reference-counting error and
+will not have to continually check error returns from the Python C
+API. CXX/Objects integrates Python with C++ in these ways:
+
+ C++ exception handling is relied on to detect errors and clean
+ up. In a complicated function this is often a tremendous problem when
+ writing in C. With PyCXX, we let the compiler keep track of what
+ objects need to be dereferenced when an error occurs.
+
+ The Standard Template Library (STL) and its many algorithms plug and
play with Python containers such as lists and tuples.
- + The optional CXX/Extensions facility allows you to replace the clumsy C
+
+ The optional CXX/Extensions facility allows you to replace the clumsy C
tables with objects and method calls that define your modules and
extension objects.
-The original source will install CXX source code needed to help building
-python/C++ extension under /usr/share/python2.6/CXX which is a standard
-Debian directory. As Slackware does not have /usr/share/python2.6, I
-patched the installer to use /usr/share/CXX in order to follow the style of
-stock python packages like pygobject or pygtk. Be aware, though, that
-python packages that will use PyCXX will probably look for the needed files
-under the Debian standard path! You should investigate if their setup.py
-accept any switch to setup a different search path otherwise you will have
-to patch them.
+The original source will install CXX source code needed to help
+building python/C++ extension under /usr/share/python2.6/CXX
+which is a standard Debian directory. As Slackware does not have
+/usr/share/python2.6, I patched the installer to use /usr/share/CXX in
+order to follow the style of stock python packages like pygobject or
+pygtk. Be aware, though, that python packages that will use PyCXX will
+probably look for the needed files under the Debian standard path! You
+should investigate if their setup.py accept any switch to setup a
+different search path otherwise you will have to patch them.