summaryrefslogtreecommitdiffstats
path: root/python/pickleshare
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2017-01-23 18:28:03 +0100
committer David Spencer2017-01-24 01:21:54 +0100
commitf176803a18b766ab756586daea81e48351264469 (patch)
treec3a8f0efc46c9ed93b14eaaf396329c0e19be7af /python/pickleshare
parent3aebdec146d8388febe25aea523212f03334ba97 (diff)
downloadslackbuilds-f176803a18b766ab756586daea81e48351264469.tar.gz
python/pickleshare: Added (database using Python pickles).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/pickleshare')
-rw-r--r--python/pickleshare/README9
-rw-r--r--python/pickleshare/pickleshare.SlackBuild87
-rw-r--r--python/pickleshare/pickleshare.info10
-rw-r--r--python/pickleshare/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/pickleshare/README b/python/pickleshare/README
new file mode 100644
index 0000000000..c7c034a911
--- /dev/null
+++ b/python/pickleshare/README
@@ -0,0 +1,9 @@
+PickleShare is a small shelve-like datastore with concurrency support.
+
+Like shelve, a PickleShareDB object acts like a normal dictionary. Unlike
+shelve, many processes can access the database simultaneously. Changing a value
+in database is immediately visible to other processes accessing the same
+database.
+
+Concurrency is possible because the values are stored in separate files. Hence
+the "database" is a directory where all files are governed by PickleShare.
diff --git a/python/pickleshare/pickleshare.SlackBuild b/python/pickleshare/pickleshare.SlackBuild
new file mode 100644
index 0000000000..435e5904fa
--- /dev/null
+++ b/python/pickleshare/pickleshare.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for pickleshare
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pickleshare
+VERSION=${VERSION:-0.7.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pickleshare/pickleshare.info b/python/pickleshare/pickleshare.info
new file mode 100644
index 0000000000..b2a522126d
--- /dev/null
+++ b/python/pickleshare/pickleshare.info
@@ -0,0 +1,10 @@
+PRGNAM="pickleshare"
+VERSION="0.7.4"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://github.com/pickleshare/pickleshare/archive/0.7.4/pickleshare-0.7.4.tar.gz"
+MD5SUM="edd1fc04bc12d9748c852218d2cb86fd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pathlib"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/pickleshare/slack-desc b/python/pickleshare/slack-desc
new file mode 100644
index 0000000000..247c8613bd
--- /dev/null
+++ b/python/pickleshare/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pickleshare: pickleshare (file system based database that uses Python pickles)
+pickleshare:
+pickleshare: PickleShare is a small shelve-like datastore with concurrency
+pickleshare: support.
+pickleshare:
+pickleshare: Like shelve, a PickleShareDB object acts like a normal dictionary.
+pickleshare: Unlike shelve, many processes can access the database simultaneously.
+pickleshare: Changing a value in database is immediately visible to other
+pickleshare: processes accessing the same database.
+pickleshare:
+pickleshare: