summaryrefslogtreecommitdiffstats
path: root/python/celery
diff options
context:
space:
mode:
author Arn02022-03-08 20:19:41 +0100
committer Willy Sudiarto Raharjo2022-03-09 03:36:27 +0100
commit9a9964d19d161cf72df17316790e821f55056884 (patch)
tree1ddc1fe54fd85562934b459f2f291d33c5ba0b67 /python/celery
parent9ce37db212d37691272b60a77554e8d7e9a97a18 (diff)
downloadslackbuilds-9a9964d19d161cf72df17316790e821f55056884.tar.gz
python/python3-celery: renamed from celery for python3, updated for version 5.2.3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/celery')
-rw-r--r--python/celery/README14
-rw-r--r--python/celery/celery.SlackBuild77
-rw-r--r--python/celery/celery.info10
-rw-r--r--python/celery/slack-desc19
4 files changed, 0 insertions, 120 deletions
diff --git a/python/celery/README b/python/celery/README
deleted file mode 100644
index 6bc0f28112..0000000000
--- a/python/celery/README
+++ /dev/null
@@ -1,14 +0,0 @@
-Distributed Task Queue
-
-Task queues are used as a mechanism to distribute work across threads or
-machines.
-
-A task queue's input is a unit of work, called a task, dedicated worker
-processes then constantly monitor the queue for new work to perform.
-
-Celery communicates via messages, usually using a broker to mediate
-between clients and workers. To initiate a task a client puts a message
-on the queue, the broker then delivers the message to a worker.
-
-A Celery system can consist of multiple workers and brokers, giving way
-to high availability and horizontal scaling.
diff --git a/python/celery/celery.SlackBuild b/python/celery/celery.SlackBuild
deleted file mode 100644
index 9e0734b3ef..0000000000
--- a/python/celery/celery.SlackBuild
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/bash
-
-# SlackBuild script for celery.
-# Yth | Pont-en-Royans, France | yth@ythogtha.org
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=celery
-VERSION=${VERSION:-3.1.26.post2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/celery/celery.info b/python/celery/celery.info
deleted file mode 100644
index 7a0e09c0f3..0000000000
--- a/python/celery/celery.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="celery"
-VERSION="3.1.26.post2"
-HOMEPAGE="http://celeryproject.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/c/celery/celery-3.1.26.post2.tar.gz"
-MD5SUM="a16881249d81591cdf5ce0dfb092ea80"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pytz kombu billiard"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/celery/slack-desc b/python/celery/slack-desc
deleted file mode 100644
index 0140c472a0..0000000000
--- a/python/celery/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-celery: celery (Distributed Task Queue)
-celery:
-celery: Task queues are used as a mechanism to distribute work across threads
-celery: or machines.
-celery:
-celery:
-celery:
-celery:
-celery:
-celery:
-celery: