summaryrefslogtreecommitdiffstats
path: root/python/BeautifulSoup4
diff options
context:
space:
mode:
author Giancarlo Dessì2023-06-17 02:15:45 +0200
committer Willy Sudiarto Raharjo2023-06-17 02:15:45 +0200
commit059c26695de82c94e1286c84b399f1e2e1992189 (patch)
treef9b5235d8a41e6ed36a11acb37bc6d9853ab2487 /python/BeautifulSoup4
parent77f45acd780eb4a12d70c94bedd8d3aa2dcd9a50 (diff)
downloadslackbuilds-059c26695de82c94e1286c84b399f1e2e1992189.tar.gz
python/BeautifulSoup4: Updated for version 2.4.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/BeautifulSoup4')
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.SlackBuild25
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.info12
-rw-r--r--python/BeautifulSoup4/README3
3 files changed, 14 insertions, 26 deletions
diff --git a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 33b6e5cf9e..84efc59209 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -4,6 +4,7 @@
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
# Copyright 2020-2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Giancarlo Dessì, Cagliari, IT, <slack@giand.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=BeautifulSoup4
-VERSION=${VERSION:-4.10.0}
+VERSION=${VERSION:-4.12.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,13 +66,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md COPYING.txt LICENSE NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG LICENSE NEWS.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/BeautifulSoup4/BeautifulSoup4.info b/python/BeautifulSoup4/BeautifulSoup4.info
index 77f81b8844..c1ca4db0c8 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.info
+++ b/python/BeautifulSoup4/BeautifulSoup4.info
@@ -1,10 +1,10 @@
PRGNAM="BeautifulSoup4"
-VERSION="4.10.0"
+VERSION="4.12.2"
HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/"
-DOWNLOAD="https://files.pythonhosted.org/packages/a1/69/daeee6d8f22c997e522cdbeb59641c4d31ab120aba0f2c799500f7456b7e/beautifulsoup4-4.10.0.tar.gz"
-MD5SUM="e754242642253dd31d249d00358d552e"
+DOWNLOAD="https://files.pythonhosted.org/packages/af/0b/44c39cf3b18a9280950ad63a579ce395dda4c32193ee9da7ff0aed547094/beautifulsoup4-4.12.2.tar.gz"
+MD5SUM="b49a6696a762e946c2be97c36a5adaa8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-soupsieve"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu@protonmail.com"
+REQUIRES="python3-build python3-hatchling python3-installer python3-soupsieve"
+MAINTAINER="Giancarlo Dessì"
+EMAIL="slack@giand.it"
diff --git a/python/BeautifulSoup4/README b/python/BeautifulSoup4/README
index adabd10335..982b5b7c41 100644
--- a/python/BeautifulSoup4/README
+++ b/python/BeautifulSoup4/README
@@ -4,3 +4,6 @@ programmers hours or days of work.
Beautiful Soup >= 4.10.0 has dropped Python 2 support. The
python2-BeautifulSoup4 SlackBuild is available at version 4.9.3.
+
+python3-build, python3-hatchling, python3-installer are
+dependencies required for the build only.