summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Michiel van Wessem2010-05-13 00:39:01 +0200
committer Robby Workman2010-05-13 00:39:01 +0200
commit86d02a18e417a40dc21be061d793f8bc7e1f8584 (patch)
tree6668bca7ffe4e2132c6c98ebbe986e4f5bb21033 /office
parent1eec7f418b26946478748c5e9d8e076a8c6b31b7 (diff)
downloadslackbuilds-86d02a18e417a40dc21be061d793f8bc7e1f8584.tar.gz
office/calcurse: Updated for version 2.7
Diffstat (limited to 'office')
-rw-r--r--office/calcurse/calcurse.SlackBuild32
-rw-r--r--office/calcurse/calcurse.info11
-rw-r--r--office/calcurse/slack-desc2
3 files changed, 26 insertions, 19 deletions
diff --git a/office/calcurse/calcurse.SlackBuild b/office/calcurse/calcurse.SlackBuild
index 549b28f043..ea05759132 100644
--- a/office/calcurse/calcurse.SlackBuild
+++ b/office/calcurse/calcurse.SlackBuild
@@ -1,6 +1,7 @@
#!/bin/sh
# Slackware build script for calcurse
+
# Copyright 2007-2009 Michiel van Wessem, Manchester, United Kingdom
# All rights reserved.
#
@@ -24,7 +25,7 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=calcurse
-VERSION=${VERSION:-2.5}
+VERSION=${VERSION:-2.7}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -34,6 +35,16 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
set -e # Exit on most errors
@@ -54,25 +65,20 @@ CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--build=$ARCH-slackware-linux \
-# Make sure we have the right compile flags set as calcurse seems to
-# blatantly ignore this: no matter what we do.
-if [ "$ARCH" = "i486" ]; then
- sed -i 's#CFLAGS = -O2 -Wall -g#CFLAGS="-O2 -march=i486 -mtune=i686 -Wall -g"#g' $TMP/$PRGNAM-$VERSION/Makefile
-elif [ "$ARCH" = "i686" ]; then
- sed -i 's#CFLAGS = -O2 -Wall -g#CFLAGS="-O2 -march=i686 -mtune=i686 -Wall -g"#g' $TMP/$PRGNAM-$VERSION/Makefile
-fi
-
make
make install-strip DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
@@ -81,7 +87,7 @@ make install-strip DESTDIR=$PKG
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO doc/* \
+cp -a ABOUT-NLS AUTHORS ChangeLog NEWS README TODO doc/* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \;
@@ -90,4 +96,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/calcurse/calcurse.info b/office/calcurse/calcurse.info
index a353536352..3752f07ee9 100644
--- a/office/calcurse/calcurse.info
+++ b/office/calcurse/calcurse.info
@@ -1,9 +1,10 @@
PRGNAM="calcurse"
-VERSION="2.5"
+VERSION="2.7"
HOMEPAGE="http://culot.org/calcurse/"
-DOWNLOAD="http://culot.org/cgi-bin/get.cgi?calcurse-2.5.tar.gz"
-MD5SUM="7868f67c49b426e3ab4a4d34ce16ef1d"
+DOWNLOAD="http://culot.org/cgi-bin/get.cgi?calcurse-2.7.tar.gz"
+MD5SUM="eddfae36370fd89532149fe80c312e1e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="Michiel van Wessem"
EMAIL="michiel@slackbuilds.org"
-APPROVED="dsomero"
-
+APPROVED="rworkman"
diff --git a/office/calcurse/slack-desc b/office/calcurse/slack-desc
index 3333bdf9e7..702d8a427c 100644
--- a/office/calcurse/slack-desc
+++ b/office/calcurse/slack-desc
@@ -13,7 +13,7 @@ calcurse: you to keep track of your appointments and everyday tasks. CalCurse
calcurse: has a nice textmode interface with configurable color schemes,
calcurse: configurable layout and Vi-like keybindings.
calcurse:
-calcurse:
calcurse: Homepage: http://culot.org/calcurse/
calcurse:
calcurse:
+calcurse: