summaryrefslogtreecommitdiffstats
path: root/office/zim
diff options
context:
space:
mode:
author Brenton Earl2016-12-16 17:51:42 +0100
committer Willy Sudiarto Raharjo2016-12-16 19:18:33 +0100
commit5e139710ca902336859da9b962e8285a912ce325 (patch)
tree3a413365cb4c465377dad16fb81849f0f994f8d0 /office/zim
parent512fdb62351a2e5fa775cdb131a3113b6e1fb268 (diff)
downloadslackbuilds-5e139710ca902336859da9b962e8285a912ce325.tar.gz
office/zim: Switch to i586.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/zim')
-rw-r--r--office/zim/README28
-rw-r--r--office/zim/README.Plugins10
-rw-r--r--office/zim/zim.SlackBuild27
3 files changed, 48 insertions, 17 deletions
diff --git a/office/zim/README b/office/zim/README
index 096281ca91..438f131310 100644
--- a/office/zim/README
+++ b/office/zim/README
@@ -1,14 +1,18 @@
-Zim is a graphical text editor and organizer with wiki-like features
-such as linking to other pages in a notebook. Zim stores data in
-plain text for simplicity and transparency.
+Zim is a graphical text editor used to maintain a collection of wiki pages.
+Each page can contain links to other pages, simple formatting and images.
+Pages are stored in a folder structure, like in an outliner, and can have
+attachments. Creating a new page is as easy as linking to a nonexistent page.
+All data is stored in plain text files with wiki formatting. Various plugins
+provide additional functionality, like a task list manager, an equation
+editor, a tray icon, and support for version control.
-Among other uses, zim can be effective for brainstorming, note-taking,
-and making task lists.
-
-Zim can optionally use pyxdg and xdg-utils
-(http://portland.freedesktop.org/download/) for additional
-freedesktop.org standard support
-
-By default, zim enables the version control plugin, which can
-optionally use bzr.
+Zim can be used to:
+* Keep an archive of notes
+* Take notes during meetings or lectures
+* Organize task lists
+* Draft blog entries and emails
+* Do brainstorming
+Optional Dependencies:
+* pyxdg - Provides further freedesktop.org standard support
+* See README.Plugins for a list of optional dependencies for plugins
diff --git a/office/zim/README.Plugins b/office/zim/README.Plugins
new file mode 100644
index 0000000000..c372fc051a
--- /dev/null
+++ b/office/zim/README.Plugins
@@ -0,0 +1,10 @@
+This file lists Zim plugins that require optional dependencies to
+function. Plugins that work out of the box with Slackware are not
+listed. Plugins that require a dependency unavailable from
+SlackBuilds.org are not listed either.
+
+* Insert Diagram: Graphviz
+* Insert Score: lilypond
+* Link Map: Graphviz
+* Source View: pygtksourceview
+* Spell Checker: pygtkspell
diff --git a/office/zim/zim.SlackBuild b/office/zim/zim.SlackBuild
index 6641de2991..cd50dbbb98 100644
--- a/office/zim/zim.SlackBuild
+++ b/office/zim/zim.SlackBuild
@@ -2,10 +2,8 @@
# Slackware build script for zim
-# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
-# All rights reserved.
-#
# Copyright 2013 Michael Ren <micron33@gmail.com>
+# Copyright 2015-2016 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -32,7 +30,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -45,7 +43,21 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="CHANGELOG.txt LICENSE.txt PKG-INFO README.txt"
-set -e
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -65,11 +77,16 @@ find -L . \
# ("automation"), hence --skip-xdg-cmd
python setup.py install --root=$PKG --skip-xdg-cmd
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/README.Plugins > $PKG/usr/doc/$PRGNAM-$VERSION/README.Plugins
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install