summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author dsomero2010-05-21 03:15:05 +0200
committer David Somero2010-05-21 07:34:40 +0200
commit32f321e4973c7591bc894abcf32fbe2952246592 (patch)
tree901e7a1f43d13ac15d1387b9b931161fd20b06fc /network
parent20443b8ecf9e0135e87c04491eda6fbc0a481be7 (diff)
downloadslackbuilds-32f321e4973c7591bc894abcf32fbe2952246592.tar.gz
network/iscsitarget: Removed (build failure)
Diffstat (limited to 'network')
-rw-r--r--network/iscsitarget/README5
-rw-r--r--network/iscsitarget/doinst.sh36
-rw-r--r--network/iscsitarget/iscsi-target-1.4.19-add-CFLAGS.patch8
-rw-r--r--network/iscsitarget/iscsitarget.SlackBuild103
-rw-r--r--network/iscsitarget/iscsitarget.info10
-rw-r--r--network/iscsitarget/rc.iscsi-target.new90
-rw-r--r--network/iscsitarget/slack-desc17
7 files changed, 0 insertions, 269 deletions
diff --git a/network/iscsitarget/README b/network/iscsitarget/README
deleted file mode 100644
index 20a52e1e95..0000000000
--- a/network/iscsitarget/README
+++ /dev/null
@@ -1,5 +0,0 @@
-The aim of the project is to develop an open source iSCSI target with
-professional features, that works well in enterprise environment under
-real workload, and is scalable and versatile enough to meet the challenge
-of future storage needs and developments. This package makes all bindings
-that are supported on the system.
diff --git a/network/iscsitarget/doinst.sh b/network/iscsitarget/doinst.sh
deleted file mode 100644
index 9ff0023984..0000000000
--- a/network/iscsitarget/doinst.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-# Keep same perms on rc.iscsi-target.new:
-if [ -e etc/rc.d/rc.iscsi-target ]; then
- cp -a etc/rc.d/rc.iscsi-target etc/rc.d/rc.iscsi-target.new.incoming
- cat etc/rc.d/rc.iscsi-target.new > etc/rc.d/rc.iscsi-target.new.incoming
- mv etc/rc.d/rc.iscsi-target.new.incoming etc/rc.d/rc.iscsi-target.new
-else
- # Install executable otherwise - irrelevant unless user starts in rc.local
- chmod 0755 etc/rc.d/rc.iscsi-target.new
-fi
-
-if [ -f /etc/ietd.conf ];then
-echo -en "\n\n\n!! iSCSI-target has recently changed the default location for conf files !!\n"
-echo -en "The new location for conf files is now at /etc/iet\n"
-echo -en "Furthermore the conf file initiators.deny is obsolete. \nFor futher info read the Man page\n\n\n"
-fi
-
-config etc/rc.d/rc.iscsi-target.new
-config etc/iet/ietd.conf.new
-config etc/iet/targets.allow.new
-config etc/iet/initiators.allow.new
-
-chroot . depmod -a @KERNEL@ 2>/dev/null 1>/dev/null
-
diff --git a/network/iscsitarget/iscsi-target-1.4.19-add-CFLAGS.patch b/network/iscsitarget/iscsi-target-1.4.19-add-CFLAGS.patch
deleted file mode 100644
index 79ec4b48f0..0000000000
--- a/network/iscsitarget/iscsi-target-1.4.19-add-CFLAGS.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- iscsitarget-1.4.19-source/usr/Makefile 2008-06-19 00:10:19.000000000 +0100
-+++ iscsitarget-1.4.19/usr/Makefile 2010-01-09 17:32:28.000000000 +0000
-@@ -1,4 +1,4 @@
--CFLAGS += -O2 -fno-inline -Wall -Wstrict-prototypes -g -I../include
-+CFLAGS += @ARCH@ -fno-inline -Wall -Wstrict-prototypes -g -I../include
- CFLAGS += -D_GNU_SOURCE # required for glibc >= 2.8
- PROGRAMS = ietd ietadm
- LIBS = -lcrypto
diff --git a/network/iscsitarget/iscsitarget.SlackBuild b/network/iscsitarget/iscsitarget.SlackBuild
deleted file mode 100644
index 9b3f5f6ee7..0000000000
--- a/network/iscsitarget/iscsitarget.SlackBuild
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/sh
-
-# Slackware SlackBuild script
-# ===========================
-# By: Thales A. Tsailas <ttsailas@enforcingit.com>
-# For: iSCSI target
-# Descr: Provides an iSCSI target solution for Linux
-# URL: http://iscsitarget.sourceforge.net/
-#
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=iscsitarget
-VERSION=1.4.19
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-KERNEL=${KERNEL:-$(uname -r)}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $TMP/$PRGNAM-$VERSION
-chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
-
-# Set right ARCH on SLKCFLAGS patch
-# Allow use of our SLKCFLAGS for the non-kernel parts
-sed "s/@ARCH@/$SLKCFLAGS/" $CWD/iscsi-target-1.4.19-add-CFLAGS.patch | patch -p1 || exit 1
-
-make \
- MANDIR=/usr/man \
- DOCDIR=/usr/doc/$PRGNAM-$VERSION \
- KSRC=/lib/modules/$KERNEL/build
-make install \
- MANDIR=/usr/man \
- DOCDIR=/usr/doc/$PRGNAM-$VERSION \
- KSRC=/lib/modules/$KERNEL/build \
- DISTDIR=$PKG
-
-# Scrap original init file and don't clobber existing config files on upgrade
-cat $CWD/rc.iscsi-target.new > $PKG/etc/rc.d/rc.iscsi-target.new
-mv $PKG/etc/iet/ietd.conf $PKG/etc/iet/ietd.conf.new
-mv $PKG/etc/iet/initiators.allow $PKG/etc/iet/initiators.allow.new
-mv $PKG/etc/iet/targets.allow $PKG/etc/iet/targets.allow.new
-
-# Add the build script to the docs
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Remove some cruft that shouldn't be in the package
-rm -f $PKG/lib/modules/$KERNEL/modules*
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man || exit 1
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/iscsitarget/iscsitarget.info b/network/iscsitarget/iscsitarget.info
deleted file mode 100644
index 012d269ec1..0000000000
--- a/network/iscsitarget/iscsitarget.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="iscsitarget"
-VERSION="1.4.19"
-HOMEPAGE="http://iscsitarget.sourceforge.net/"
-DOWNLOAD="http://download.sourceforge.net/iscsitarget/iscsitarget-1.4.19.tar.gz"
-MD5SUM="9beca214c28949cce1716b49fec57de4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Thales A. Tsailas"
-EMAIL="ttsailas@enforcingit.com"
-APPROVED="rworkman"
diff --git a/network/iscsitarget/rc.iscsi-target.new b/network/iscsitarget/rc.iscsi-target.new
deleted file mode 100644
index acfbe38c85..0000000000
--- a/network/iscsitarget/rc.iscsi-target.new
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/bash
-
-# Written by Thales A. Tsailas <ttsailas@enforcingit.com>
-# Init script for the iSCSI Enterprise Target.
-# http://iscsitarget.sourceforge.net/
-# For Slackware Linux
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-CONF=/etc/iet/ietd.conf
-PID=$(pidof ietd)
-
-RETVAL=0
-
-start()
-{
- # Load necessary modules
- if [ ! "$PID" = '' ]; then
- echo -en "iSCSI enterprise target is already running\n"
- else
- echo -en "Loading iSCSI enterprise target module\n"
- modprobe iscsi_trgt
- echo -en "Starting iSCSI enterprise target..."
- /usr/sbin/ietd -c $CONF
- sleep 1
-
- if [ $RETVAL = "0" ]; then
- echo -en "done.\n"
- else
- echo -en "failed.\n"
- exit $RETVAL
- fi
- fi
-
-}
-
-stop()
-{
- if [ "$PID" = '' ]; then
- echo -en "iSCSI enterprise target is not running\n"
- else
- echo -en "Stoping iSCSI enterprise target...\n"
- ietadm --op delete
- kill -9 $PID
- echo -en "Unloading iSCSI enterprise target modules"
- modprobe -r iscsi_trgt
- sleep 1
- if [ $RETVAL = "0" ]; then
- echo -en "done.\n"
- else
- echo -en "failed.\n"
- exit $RETVAL
- fi
- fi
-
-
-}
-
-status()
-{
- if [ "$PID" = '' ]; then
- echo -en "iSCSI enterprise target is not running\n"
- else
- echo -en "iSCSI enterprise target is running with pid: \033[1m$PID\e[0m\n"
- echo -en "Available targets:\n"
- cat /proc/net/iet/session
- fi
-
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart)
- stop
- start
- ;;
- status)
- status
- ;;
- *)
- echo "Usage: {start|stop|restart|status}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/network/iscsitarget/slack-desc b/network/iscsitarget/slack-desc
deleted file mode 100644
index 165eae416f..0000000000
--- a/network/iscsitarget/slack-desc
+++ /dev/null
@@ -1,17 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-iscsitarget: iscsitarget (iSCSI Enterprise Target)
-iscsitarget:
-iscsitarget: iSCSI Enterprise Target is for building an iSCSI storage system
-iscsitarget: on Linux. It is aimed at developing an iSCSI target satisfying
-iscsitarget: enterprise requirements.
-iscsitarget:
-iscsitarget: http://iscsitarget.sourceforge.net/
-iscsitarget:
-iscsitarget: