summaryrefslogtreecommitdiffstats
path: root/network/wireshark/wireshark.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2019-03-02 01:37:52 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:14 +0100
commitd307482fe0e38020f0cc04baea2a2077a5ff5feb (patch)
tree4b86002b840ca08a29e54b4bc1b57931c62597af /network/wireshark/wireshark.SlackBuild
parente5127021a37935871aacbd31497c73342e0d8e3f (diff)
downloadslackbuilds-d307482fe0e38020f0cc04baea2a2077a5ff5feb.tar.gz
network/wireshark: Updated for version 3.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/wireshark/wireshark.SlackBuild')
-rw-r--r--network/wireshark/wireshark.SlackBuild45
1 files changed, 17 insertions, 28 deletions
diff --git a/network/wireshark/wireshark.SlackBuild b/network/wireshark/wireshark.SlackBuild
index 743eb6f43b..f06818c8ee 100644
--- a/network/wireshark/wireshark.SlackBuild
+++ b/network/wireshark/wireshark.SlackBuild
@@ -30,7 +30,7 @@
# Modified by B. Watson <yalhcru@gmail.com> to add lua52 support.
PRGNAM=wireshark
-VERSION=${VERSION:-2.6.7}
+VERSION=${VERSION:-3.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,10 +73,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Ammend hardcoded paths to /usr/lib/ which will give a problem when compiling on
-# systems with 32bit compat libs install. Thanks to Heinz Wiesinger.
-sed -i "s|/lib)|/lib$LIBDIRSUFFIX)|g" configure.ac
-
# We have 3 lua versions on SBo: lua is v5.1, lua52 is 5.2, lua53 is 5.3.
# Wireshark only supports 5.1 and 5.2, not 5.3. The lua version doesn't
# affect core wireshark, only 3rd-party plugins written in lua. Most
@@ -94,36 +90,29 @@ else
echo "=== Building with lua (v5.1)"
fi
-# run autoreconf so it'll use the correct automake version.
-autoreconf -f -i
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --with-ssl=/usr/lib${LIBDIRSUFFIX} \
- --enable-packet-editor \
- --enable-setuid-install \
- --with-gtk=3 \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr/
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/include/$PRGNAM/{epan/{crypt,dfilter,dissectors,ftypes,wmem},wiretap,wsutil}
-install -m644 config.h ws_diag_control.h ws_symbol_export.h $PKG/usr/include/$PRGNAM
- for d in epan epan/crypt epan/dfilter epan/dissectors epan/ftypes epan/wmem wiretap wsutil; do
+install -m644 ws_diag_control.h ws_symbol_export.h $PKG/usr/include/$PRGNAM
+ for d in epan epan/crypt epan/dfilter epan/dissectors epan/ftypes epan/wmem; do
install -m644 $d/*.h $PKG/usr/include/$PRGNAM/$d
done
@@ -134,7 +123,7 @@ cp $PRGNAM.desktop $PKG/usr/share/applications
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS* COPYING ChangeLog INSTALL* NEWS README* doc/READM* \
+cp -a AUTHORS* COPYING ChangeLog INSTALL NEWS README* doc/READM* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild