summaryrefslogtreecommitdiffstats
path: root/network/transmission/transmission.SlackBuild
diff options
context:
space:
mode:
author Niels Horn2011-04-03 21:26:49 +0200
committer Niels Horn2011-04-03 21:26:49 +0200
commit334c8132f03980092cddc0affbf8424cafc4476f (patch)
tree72bb687ebca25e5b553a1704ea3936011a845348 /network/transmission/transmission.SlackBuild
parent953083e068433d3db257a718d2930b5ffa2bc7b4 (diff)
downloadslackbuilds-334c8132f03980092cddc0affbf8424cafc4476f.tar.gz
network/transmission: Updated for version 2.22.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'network/transmission/transmission.SlackBuild')
-rw-r--r--network/transmission/transmission.SlackBuild38
1 files changed, 21 insertions, 17 deletions
diff --git a/network/transmission/transmission.SlackBuild b/network/transmission/transmission.SlackBuild
index c472472414..2fc1ccf939 100644
--- a/network/transmission/transmission.SlackBuild
+++ b/network/transmission/transmission.SlackBuild
@@ -2,8 +2,11 @@
# Slackware build script for transmission
# Written by Iskar Enev <iskar.enev[@]gmail.com>
+# As of version 2.22 maintained by Niels Horn <niels.horn@gmail.com>
+# Revision date: 2011/04/01
+
PRGNAM=transmission
-VERSION=2.03
+VERSION=${VERSION:-2.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,6 +54,9 @@ chmod -R a-s,u+w,go+r-w .
sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
sed -i -e 's%-ggdb3 %%g' configure.ac
+# Fix hard-coded path of man file of Qt client
+sed -i "s|share/man/|man/|" qt/qtr.pro
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -64,28 +70,26 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux \
--host=$ARCH-slackware-linux
+# build daemon, GTK and cli client
make
make install DESTDIR=$PKG
-# build the Qt client (qtr)
-( cd $TMP/$PRGNAM-$VERSION/qt
- qmake "QMAKE_CXXFLAGS+=$SLKCFLAGS" "QMAKE_CFLAGS+=$SLKCFLAGS" qtr.pro
+# build the Qt client (transmission-qt)
+cd $TMP/$PRGNAM-$VERSION/qt
+ qmake \
+ QMAKE_CXXFLAGS+="$SLKCFLAGS" \
+ QMAKE_CFLAGS+="$SLKCFLAGS" \
+ qtr.pro
sed -i -e 's% -g % %g' Makefile
make
INSTALL_ROOT=$PKG/usr make install
-)
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+cd -
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCUMENTATION $PKG/usr/doc/$PRGNAM-$VERSION