summaryrefslogtreecommitdiffstats
path: root/network/roger-router
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-02-17 05:58:10 +0100
committer Willy Sudiarto Raharjo2022-02-17 05:58:10 +0100
commit76e3f6e1d1908f9f91b334b0389cab56d42fe86c (patch)
tree99cdd3360942969a2f1791d64919fc2854b0183b /network/roger-router
parentcf52587c33ad01f0c4bc75dd3affc207f87ce4b5 (diff)
downloadslackbuilds-76e3f6e1d1908f9f91b334b0389cab56d42fe86c.tar.gz
network/roger-router: Removed (source only for flatpak).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/roger-router')
-rw-r--r--network/roger-router/README31
-rw-r--r--network/roger-router/doinst.sh15
-rw-r--r--network/roger-router/roger-router.SlackBuild142
-rw-r--r--network/roger-router/roger-router.info10
-rw-r--r--network/roger-router/slack-desc19
5 files changed, 0 insertions, 217 deletions
diff --git a/network/roger-router/README b/network/roger-router/README
deleted file mode 100644
index fddd2add07..0000000000
--- a/network/roger-router/README
+++ /dev/null
@@ -1,31 +0,0 @@
-Roger-Router (former FFGTK Router Manager)
-
-Fax-Software and Call-Monitor for AVM FRITZ!Box or compatible
-
-
-To install a Fax-printer you can use (as root-user):
-
- sh /usr/share/roger/install-fax.sh
-
-
-Optional Dependencies
-
-There is an optional firefox-plugin "roger-dial". It can be installed by
-calling https://www.tabos.org/wp-content/uploads/tabos/roger-dial-1.8.1.xpi
-from your firefox browser.
-
-
-Groupname and Username
-
-You must have the group 'fax' to run this script, for example:
-
- groupadd -g 273 fax
-
-In order to enable fax transfers, your user must be a member of the
-'fax' group. Use
-
- gpasswd -a <username> fax
-
-as the root user to add the user <username> to the group fax,
-and then log out and log in again as <username>. (Replace <username>
-with the real user name on your system.)
diff --git a/network/roger-router/doinst.sh b/network/roger-router/doinst.sh
deleted file mode 100644
index 401d987795..0000000000
--- a/network/roger-router/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
-if [ -e usr/share/glib-2.0/schemas ]; then
- if [ -x /usr/bin/glib-compile-schemas ]; then
- /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
- fi
-fi
diff --git a/network/roger-router/roger-router.SlackBuild b/network/roger-router/roger-router.SlackBuild
deleted file mode 100644
index 9ab0a9dd31..0000000000
--- a/network/roger-router/roger-router.SlackBuild
+++ /dev/null
@@ -1,142 +0,0 @@
-#!/bin/bash
-#
-# Slackware build script for roger-router
-#
-# Copyright 2015 Marek Srejma (sam_web@yahoo.de)
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=roger-router
-VERSION=${VERSION:-1.9.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-bailout() {
- echo " You must have fax group:"
- echo " # groupadd -g 273 fax"
- exit 1
-}
-
-# Bail if group isn't valid on your system
-if ! getent group fax 1>/dev/null 2>/dev/null ; then
- bailout
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-./autogen.sh
-CXXFLAGS="$SLKCFLAGS" \
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --build=$ARCH-slackware-linux
-
-for d in "." "doc" "roger" "roger-cli"
-do
- sed \
- -e '/^SPANDSP_LIBS\s*=/ s|-L.*/|-L/usr/|' \
- -i ${d}/Makefile
-done
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr/man
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-sed \
- -e 's|/lib|/lib'${LIBDIRSUFFIX}'|' \
- -e '/^cp\s*/ s|roger-cups|/usr/share/roger/roger-cups|' \
- -e '/^lpadmin/ s|roger-fax.ppd|/usr/share/roger/roger-fax.ppd|' \
- -i $PKG/usr/share/roger/install-fax.sh
-
-# content of /usr/share/roger/install-fax.sh
-mkdir -p $PKG/var/spool/roger/ $PKG/usr/lib${LIBDIRSUFFIX}/cups/backend/
-chown lp:fax $PKG/var/spool/roger
-chmod 2770 $PKG/var/spool/roger/
-cp $PKG/usr/share/roger/roger-cups $PKG/usr/lib${LIBDIRSUFFIX}/cups/backend/
-chown root:root $PKG/usr/lib${LIBDIRSUFFIX}/cups/backend/roger-cups
-chmod 0755 $PKG/usr/lib${LIBDIRSUFFIX}/cups/backend/roger-cups
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog NEWS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/roger-router/roger-router.info b/network/roger-router/roger-router.info
deleted file mode 100644
index 8654fda0d6..0000000000
--- a/network/roger-router/roger-router.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="roger-router"
-VERSION="1.9.3"
-HOMEPAGE="https://www.tabos.org/"
-DOWNLOAD="https://www.tabos.org/wp-content/uploads/tabos/roger-router-1.9.3.tar.xz"
-MD5SUM="78c4b41b2c3dceb41cb15215f51b0bb8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="libpeas spandsp libcapi20 gupnp"
-MAINTAINER="Marek Srejma"
-EMAIL="sam_web@yahoo.de"
diff --git a/network/roger-router/slack-desc b/network/roger-router/slack-desc
deleted file mode 100644
index 961d48d036..0000000000
--- a/network/roger-router/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-roger-router: roger-router (former FFGTK Router Manager)
-roger-router:
-roger-router: Fax-Software and Call-Monitor for AVM FRITZ!Box or compatible
-roger-router:
-roger-router:
-roger-router: https://www.tabos.org/
-roger-router:
-roger-router:
-roger-router:
-roger-router:
-roger-router: