summaryrefslogtreecommitdiffstats
path: root/network/pebrot
diff options
context:
space:
mode:
author Martin Lefebvre2010-05-11 15:01:33 +0200
committer Robby Workman2010-05-11 15:01:33 +0200
commit2f53017ebc85ef6aebd482ffe0367fcc258773bc (patch)
tree7e59a8dcebadd343ec0b1b3e3a43711dc9f640f6 /network/pebrot
parent642d0fa784341d39a8ef761728ab6c401db41d69 (diff)
downloadslackbuilds-2f53017ebc85ef6aebd482ffe0367fcc258773bc.tar.gz
network/pebrot: Initial import
Diffstat (limited to 'network/pebrot')
-rw-r--r--network/pebrot/README4
-rw-r--r--network/pebrot/pebrot.SlackBuild59
-rw-r--r--network/pebrot/pebrot.info8
-rw-r--r--network/pebrot/slack-desc8
4 files changed, 79 insertions, 0 deletions
diff --git a/network/pebrot/README b/network/pebrot/README
new file mode 100644
index 0000000000..d81d22ca7f
--- /dev/null
+++ b/network/pebrot/README
@@ -0,0 +1,4 @@
+pebrot is a client for the MSN Messenger protocol written
+in Python. It includes the client, and a python class that
+can be used by other clients or programs.
+
diff --git a/network/pebrot/pebrot.SlackBuild b/network/pebrot/pebrot.SlackBuild
new file mode 100644
index 0000000000..5329689f56
--- /dev/null
+++ b/network/pebrot/pebrot.SlackBuild
@@ -0,0 +1,59 @@
+#!/bin/sh
+
+# Slackware build script for pebrot
+
+# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuilds.org project
+
+set -e
+
+PRGNAM=pebrot
+VERSION=0.8.8
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python ./setup.py install --prefix=$PKG/usr
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PKG/usr/share/doc/pebrot/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/doc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/pebrot/pebrot.info b/network/pebrot/pebrot.info
new file mode 100644
index 0000000000..cfaf8afd8a
--- /dev/null
+++ b/network/pebrot/pebrot.info
@@ -0,0 +1,8 @@
+PRGNAM="pebrot"
+VERSION="0.8.8"
+HOMEPAGE="http://pebrot.sf.net"
+DOWNLOAD="http://dl.sourceforge.net/pebrot/pebrot-0.8.8.tar.bz2"
+MD5SUM="aa07bcb3cb7556bdd20a42b48ac45643"
+MAINTAINER="Martin Lefebvre"
+EMAIL="dadexter@gmail.com"
+APPROVED="robw810"
diff --git a/network/pebrot/slack-desc b/network/pebrot/slack-desc
new file mode 100644
index 0000000000..140030d79e
--- /dev/null
+++ b/network/pebrot/slack-desc
@@ -0,0 +1,8 @@
+pebrot: pebrot MSN client
+pebrot:
+pebrot: pebrot is a client for the MSN Messenger protocol written
+pebrot: in Python. It includes the client, and a python class that
+pebrot: can be used by other clients or programs.
+pebrot:
+pebrot:
+pebrot: