summaryrefslogtreecommitdiffstats
path: root/network/kismet
diff options
context:
space:
mode:
author Audrius Kažukauskas2013-06-03 05:50:45 +0200
committer Robby Workman2013-06-04 07:11:26 +0200
commitf53b5ed1bce8bacc1f2649d69e2fa4f51fe49eef (patch)
treedf1873f455ec13bd02b472987330f26c370cd072 /network/kismet
parent4b77dd8275b1dc3deaf2f44d9184ba187c274a42 (diff)
downloadslackbuilds-f53b5ed1bce8bacc1f2649d69e2fa4f51fe49eef.tar.gz
network/kismet: Updated for version 2013_03_R1b.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/kismet')
-rw-r--r--network/kismet/kismet.SlackBuild42
-rw-r--r--network/kismet/kismet.info8
-rw-r--r--network/kismet/slack-desc12
3 files changed, 38 insertions, 24 deletions
diff --git a/network/kismet/kismet.SlackBuild b/network/kismet/kismet.SlackBuild
index 7be1f2425e..7e477e7483 100644
--- a/network/kismet/kismet.SlackBuild
+++ b/network/kismet/kismet.SlackBuild
@@ -1,12 +1,31 @@
#!/bin/sh
# Slackware build script for kismet
-# Written by Audrius Kažukauskas <audrius@neutrino.lt>
-# Modified by Robby Workman <rworkman@slackbuilds.org>
-# Modified by Antonio Hernández Blas <hba.nihilismus@gmail.com>
+
+# Copyright 2007 Robby Workman <rworkman@slackbuilds.org>
+# Copyright 2010 Antonio Hernández Blas <hba.nihilismus@gmail.com>
+# Copyright 2013 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=kismet
-VERSION=${VERSION:-2011_03_R2}
+VERSION=${VERSION:-2013_03_R1b}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,15 +75,13 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$SRCVERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$SRCVERSION.tar.xz
mv $PRGNAM-$SRCVERSION $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-sed -i "s|/lib/kismet|/lib$LIBDIRSUFFIX/kismet|" plugin-*/Makefile
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -73,6 +90,7 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc/kismet \
--localstatedir=/var \
--mandir=/usr/man \
+ --with-netlink-version=1 \
--build=$ARCH-slackware-linux
make
@@ -88,21 +106,17 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG GPL README *.txt docs/* patches/ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG README *.txt docs/* patches/ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
-# Add .new extension to all configuration files.
+# Add .new extension to all configuration files and include them in doinst.sh.
for file in $(find $PKG/etc -type f) ; do
mv $file $file.new
-done
-
-# Add *.new files into doinst.sh
-for file in $(find $PKG/etc -type f -name "*.new") ; do
- echo config $(echo $file | sed "s:$PKG/::") >> $PKG/install/doinst.sh
+ echo "config $(echo $file | sed "s|$PKG/||").new" >> $PKG/install/doinst.sh
done
cd $PKG
diff --git a/network/kismet/kismet.info b/network/kismet/kismet.info
index 1bd87a3ba9..abf2d12461 100644
--- a/network/kismet/kismet.info
+++ b/network/kismet/kismet.info
@@ -1,8 +1,8 @@
PRGNAM="kismet"
-VERSION="2011_03_R2"
-HOMEPAGE="http://kismetwireless.net/"
-DOWNLOAD="http://kismetwireless.net/code/kismet-2011-03-R2.tar.gz"
-MD5SUM="8bf077e8111e6dc8c12cadefdf40aadd"
+VERSION="2013_03_R1b"
+HOMEPAGE="https://kismetwireless.net/"
+DOWNLOAD="https://kismetwireless.net/code/kismet-2013-03-R1b.tar.xz"
+MD5SUM="596acdd2940887dd05a498ea27475eea"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/network/kismet/slack-desc b/network/kismet/slack-desc
index 43898d8471..919683bd42 100644
--- a/network/kismet/slack-desc
+++ b/network/kismet/slack-desc
@@ -1,9 +1,9 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
kismet: Kismet (wireless network detector)
@@ -14,6 +14,6 @@ kismet: which supports raw monitoring (rfmon) mode, and can sniff 802.11b,
kismet: 802.11a, 802.11g and 802.11n traffic. Kismet also supports plugins
kismet: which allow sniffing other media such as DECT.
kismet:
-kismet: Homepage: http://kismetwireless.net/
+kismet: Homepage: https://kismetwireless.net/
kismet:
kismet: