summaryrefslogtreecommitdiffstats
path: root/network/exim/exim.SlackBuild
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-13 00:08:37 +0200
committer Heinz Wiesinger2010-05-13 00:08:37 +0200
commitbee94398ad86544df421952951167b4f5ef299fb (patch)
treeb2dc298f54bc3b03dd1d3333a8253826846e03bb /network/exim/exim.SlackBuild
parent88c212d1d4cf1662d5f1053fefcd9c52dae6c48c (diff)
downloadslackbuilds-bee94398ad86544df421952951167b4f5ef299fb.tar.gz
network/exim: Removed from 13.0 repository
Diffstat (limited to 'network/exim/exim.SlackBuild')
-rw-r--r--network/exim/exim.SlackBuild123
1 files changed, 0 insertions, 123 deletions
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
deleted file mode 100644
index 3c2dd64f10..0000000000
--- a/network/exim/exim.SlackBuild
+++ /dev/null
@@ -1,123 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Exim
-# http://www.exim.org/
-# Copyright 2008 Thales A. Tsailas (ttsailas@enforcingit.com)
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# *Extensively* edited by the SlackBuilds.org project. -michiel.
-
-PRGNAM=exim
-VERSION=4.69
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-EXIMUSER=${EXIMUSER:-exim}
-EXIMGROUP=${EXIMGROUP:-exim}
-EXIMUID=${EXIMUID:-222}
-EXIMGID=${EXIMGID:-222}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-# Exit on most errors
-set -e
-
-# Check if the exim and user group exist. If not, then bail
-if ! grep ^${EXIMGROUP}: /etc/group 2>&1 > /dev/null; then
-cat << EOF
-
- You must have a ${EXIMGROUP} group to run this script.
- For example: groupadd -g ${EXIMGID} ${EXIMGROUP}
-
-EOF
- exit
-elif ! grep ^${EXIMUSER}: /etc/passwd 2>&1 > /dev/null; then
- cat << EOF
-
- You must have a ${EXIMUSER} user to run this script.
- For example: useradd -u ${EXIMUID} -d /var/spool/exim -s /bin/false -g ${EXIMGROUP} ${EXIMUSER}
-
-EOF
- exit
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Set the right compiler flags and settings.
-# Edit {exim,eximon.Makefile} if you want to change any of these.
-sed -e "s/#SLKCFLAGS#/$SLKCFLAGS/" $CWD/exim.Makefile > $TMP/$PRGNAM-$VERSION/Local/Makefile
-sed -e "s/#SLKCFLAGS#/$SLKCFLAGS/" $CWD/eximon.Makefile > $TMP/$PRGNAM-$VERSION/Local/eximon.conf
-
-make all
-make install DESTDIR=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-mkdir -p $PKG/usr/man/man8
-cat doc/$PRGNAM.8 > $PKG/usr/man/man8/$PRGNAM.8
-gzip -9 $PKG/usr/man/man8/$PRGNAM.8
-
-mkdir -p $PKG/etc/{logrotate.d,rc.d}
-cat $CWD/rc.exim.new > $PKG/etc/rc.d/rc.exim.new
-cat $CWD/$PRGNAM.logrotate > $PKG/etc/logrotate.d/$PRGNAM
-mv $PKG/etc/exim/exim.conf $PKG/etc/exim/exim.conf.new
-mv $PKG/etc/aliases $PKG/etc/aliases.new
-
-mkdir -p $PKG/var/log/exim
-mkdir -p -m 0750 $PKG/var/spool/exim/
-mkdir -p -m 0750 $PKG/var/spool/exim/{db,input,msglog}
-chown -R $EXIMUSER:$EXIMGROUP $PKG/var/{log,spool}/exim
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ABOUT ACKNOWLEDGMENTS LICENCE CHANGES doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz