summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Vijay Marcel2022-09-02 12:09:40 +0200
committer Willy Sudiarto Raharjo2022-09-03 12:58:45 +0200
commit04adf547994937d471cac8f9c157a48d47ff551b (patch)
tree5de7e0b080c2696582b4d61cd2f0a2615bce97bf /multimedia
parent8296c1e5f6b2f1aecf083c95bcbee150567bc261 (diff)
downloadslackbuilds-04adf547994937d471cac8f9c157a48d47ff551b.tar.gz
multimedia/uavs3e: Added (AVS3 Encoder)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/uavs3e/README3
-rw-r--r--multimedia/uavs3e/slack-desc19
-rw-r--r--multimedia/uavs3e/uavs3e.SlackBuild114
-rw-r--r--multimedia/uavs3e/uavs3e.info10
4 files changed, 146 insertions, 0 deletions
diff --git a/multimedia/uavs3e/README b/multimedia/uavs3e/README
new file mode 100644
index 0000000000..28e015ad27
--- /dev/null
+++ b/multimedia/uavs3e/README
@@ -0,0 +1,3 @@
+uavs3e ia an open source and cross platform avs3 encoder.
+It supports AVS3-P2 baseline profile.
+
diff --git a/multimedia/uavs3e/slack-desc b/multimedia/uavs3e/slack-desc
new file mode 100644
index 0000000000..e3ee05a48a
--- /dev/null
+++ b/multimedia/uavs3e/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+uavs3e: uavs3e (AVS3 Encoder)
+uavs3e:
+uavs3e: uavs3e ia an open source and cross platform avs3 encoder.
+uavs3e: It supports AVS3-P2 baseline profile.This is the
+uavs3e: 10-bit version of the encoder.
+uavs3e:
+uavs3e: Homepage:https://github.com/uavs3/uavs3e
+uavs3e:
+uavs3e:
+uavs3e:
+uavs3e:
diff --git a/multimedia/uavs3e/uavs3e.SlackBuild b/multimedia/uavs3e/uavs3e.SlackBuild
new file mode 100644
index 0000000000..3c6abb5b08
--- /dev/null
+++ b/multimedia/uavs3e/uavs3e.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/bash
+
+# Slackware build script for uavs3e
+
+# Copyright 2022 Vijay Marcel
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=uavs3e
+VERSION=${VERSION:-ea40065_20220823}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+GIT=${GIT:-ea40065982019a5b43f4ff61e37ba1fe7a7dbfe8}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+rm -rf $PRGNAM-$GIT
+tar xvf $CWD/$PRGNAM-$GIT.tar.gz
+cd $PRGNAM-$GIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i '62 i set(libdir "lib64")' src/CMakeLists.txt
+sed -i.bak '63d' src/CMakeLists.txt
+
+cmake -B build/linux -S $TMP/$PRGNAM-$GIT \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIB_DIR_PREFIX=/usr/lib${LIBDIRSUFFIX} \
+ -DBUILD_SHARED_LIBS:BOOL='ON' \
+ -DCOMPILE_10BIT='1'
+
+make -C build/linux
+make -C build/linux install DESTDIR=$PKG
+
+install -D -m755 $TMP/$PRGNAM-$GIT/build/linux/uavs3enc -t "${PKG}/usr/bin"
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md ProgGuide.docx $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/multimedia/uavs3e/uavs3e.info b/multimedia/uavs3e/uavs3e.info
new file mode 100644
index 0000000000..3b8a9ce9bd
--- /dev/null
+++ b/multimedia/uavs3e/uavs3e.info
@@ -0,0 +1,10 @@
+PRGNAM="uavs3e"
+VERSION="ea40065_20220823"
+HOMEPAGE="https://github.com/uavs3/uavs3e"
+DOWNLOAD="https://github.com/uavs3/uavs3e/archive/ea40065/uavs3e-ea40065982019a5b43f4ff61e37ba1fe7a7dbfe8.tar.gz"
+MD5SUM="623adc8320fcea6aa59655b7bf4744d1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymarcel@outlook.com"