summaryrefslogtreecommitdiffstats
path: root/misc/opencc
diff options
context:
space:
mode:
author Matteo Bernardini2020-12-08 11:06:03 +0100
committer Robby Workman2021-04-18 06:50:35 +0200
commitb85ee8651ea5ecb2a451a74e48d9d18a4aa9f728 (patch)
tree0168db26e22f98bca6120ef61ae84a7aacb11116 /misc/opencc
parent07b6580b91533f6663dd8b9eebff53b2ceaf22ba (diff)
downloadslackbuilds-b85ee8651ea5ecb2a451a74e48d9d18a4aa9f728.tar.gz
misc/opencc: Removed (added to Slackware as OpenCC).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'misc/opencc')
-rw-r--r--misc/opencc/README4
-rw-r--r--misc/opencc/opencc.SlackBuild89
-rw-r--r--misc/opencc/opencc.info10
-rw-r--r--misc/opencc/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/misc/opencc/README b/misc/opencc/README
deleted file mode 100644
index 0ba21ba6e1..0000000000
--- a/misc/opencc/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Open Chinese Convert (OpenCC) is an opensource project for conversion
-between Traditional Chinese and Simplified Chinese, supporting
-character-level conversion, phrase-level conversion, variant conversion
-and regional idioms among Mainland China, Taiwan and Hong kong.
diff --git a/misc/opencc/opencc.SlackBuild b/misc/opencc/opencc.SlackBuild
deleted file mode 100644
index c46eb39e14..0000000000
--- a/misc/opencc/opencc.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for OpenCC
-
-# Copyright 2015 CCHsu, Taiwan
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=opencc
-SRCNAM=OpenCC
-VERSION=${VERSION:-1.0.3}
-SRCVER=ver.$VERSION
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$SRCVER
-tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz || tar xvf $CWD/$SRCVER.tar.gz
-cd $SRCNAM-$SRCVER
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-sed -i -e "s/set (LIB_SUFFIX \"\")/set (LIB_SUFFIX \"$LIBDIRSUFFIX\")/" CMakeLists.txt
-
-make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/opencc/opencc.info b/misc/opencc/opencc.info
deleted file mode 100644
index 27e4a923cb..0000000000
--- a/misc/opencc/opencc.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="opencc"
-VERSION="1.0.3"
-HOMEPAGE="http://byvoid.github.io/OpenCC/"
-DOWNLOAD="https://github.com/BYVoid/OpenCC/archive/ver.1.0.3.tar.gz"
-MD5SUM="c196d6fe29d57b2efcc32e868f5ed21b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="CCHsu"
-EMAIL="a12321aabb@gmail.com"
diff --git a/misc/opencc/slack-desc b/misc/opencc/slack-desc
deleted file mode 100644
index f238fed167..0000000000
--- a/misc/opencc/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-opencc: opencc (Open Chinese Convert)
-opencc:
-opencc: Open Chinese Convert is an opensource project for conversion
-opencc: between Traditional Chinese and Simplified Chinese, supporting
-opencc: character-level conversion, phrase-level conversion, variant
-opencc: conversion and regional idioms among Mainland China, Taiwan and
-opencc: Hong kong.
-opencc:
-opencc: Homepage: http://byvoid.github.io/OpenCC/
-opencc:
-opencc: