summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Lionel Young2010-09-10 15:54:11 +0200
committer dsomero2010-09-10 15:54:11 +0200
commitd05d942fe4d2317e46bcd7bb7bbd5333c803f6cc (patch)
tree07646b52714421ee42e38877d20db083f81110ea /libraries
parente01963257d5dffebc13bc180d3b342c4596c732f (diff)
downloadslackbuilds-d05d942fe4d2317e46bcd7bb7bbd5333c803f6cc.tar.gz
libraries/pyffmpeg: Added (FFmpeg wrapper)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pyffmpeg/README6
-rw-r--r--libraries/pyffmpeg/pyffmpeg.SlackBuild72
-rw-r--r--libraries/pyffmpeg/pyffmpeg.info10
-rw-r--r--libraries/pyffmpeg/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/libraries/pyffmpeg/README b/libraries/pyffmpeg/README
new file mode 100644
index 0000000000..3585ec5eee
--- /dev/null
+++ b/libraries/pyffmpeg/README
@@ -0,0 +1,6 @@
+PyFFmpeg is a wrapper around FFmpeg's libavcodec, libavformat and
+libavutil libraries whose main purpose is to provide access to
+individual frames of video files of various formats (including MPEG
+and DIVX encoded videos), and, also in latest beta,to audio data.
+
+This requires Numpy, Cython, and ffmpeg.
diff --git a/libraries/pyffmpeg/pyffmpeg.SlackBuild b/libraries/pyffmpeg/pyffmpeg.SlackBuild
new file mode 100644
index 0000000000..934c08feac
--- /dev/null
+++ b/libraries/pyffmpeg/pyffmpeg.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
+
+# Slackware build script for pyffmpeg
+# Written by Lionel Young <redtricycle@gmail.com>
+# Based on http://slackbuilds.org/template.SlackBuild
+
+
+PRGNAM=pyffmpeg
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -aR examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyffmpeg/pyffmpeg.info b/libraries/pyffmpeg/pyffmpeg.info
new file mode 100644
index 0000000000..2188c06d08
--- /dev/null
+++ b/libraries/pyffmpeg/pyffmpeg.info
@@ -0,0 +1,10 @@
+PRGNAM="pyffmpeg"
+VERSION="2.0"
+HOMEPAGE="http://code.google.com/p/pyffmpeg/"
+DOWNLOAD="http://pyffmpeg.googlecode.com/files/pyffmpeg-2.0.tar.gz"
+MD5SUM="fee69342f9c7909bc0586c3e3cd4a6c2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
+APPROVED="dsomero"
diff --git a/libraries/pyffmpeg/slack-desc b/libraries/pyffmpeg/slack-desc
new file mode 100644
index 0000000000..172682956c
--- /dev/null
+++ b/libraries/pyffmpeg/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyffmpeg: pyffmpeg (FFmpeg wrapper)
+pyffmpeg:
+pyffmpeg: PyFFmpeg is a wrapper around FFmpeg's libavcodec, libavformat
+pyffmpeg: and libavutil libraries whose main purpose is to provide access to
+pyffmpeg: individual frames of video files of various formats (including MPEG
+pyffmpeg: and DIVX encoded videos), and, also in latest beta,to audio data.
+pyffmpeg: Requires: Cython, Numpy, and ffmpeg
+pyffmpeg:
+pyffmpeg: Homepage: http://code.google.com/p/pyffmpeg/
+pyffmpeg:
+pyffmpeg: