summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Christoph Willing2023-06-02 04:33:27 +0200
committer Willy Sudiarto Raharjo2023-06-03 05:38:29 +0200
commit711f58791363051e07db912c6f15be5781a2557c (patch)
tree85b66bef794cb036371117ccdcca2fde8e096b49 /libraries
parent62875008414ac218517c5b569137c5b048cd21dc (diff)
downloadslackbuilds-711f58791363051e07db912c6f15be5781a2557c.tar.gz
libraries/OpenSceneGraph: Ignore OpenCASCADE
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild21
-rw-r--r--libraries/OpenSceneGraph/README2
-rw-r--r--libraries/OpenSceneGraph/disable_asio.diff13
-rw-r--r--libraries/OpenSceneGraph/no-asio-occ.diff20
4 files changed, 25 insertions, 31 deletions
diff --git a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
index 6edeaadf7f..bcf21cc5d8 100644
--- a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
+++ b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
@@ -4,7 +4,7 @@
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
# Maintained by Jordan Evans <jordanevans19@gmail.com>
-# Maintained 2018-2021 by Christoph Willing <chris.willing@linux.com>
+# Maintained 2018-2023 by Christoph Willing <chris.willing@linux.com>
cd $(dirname $0) ; CWD=$(pwd)
@@ -48,12 +48,6 @@ else
LIBDIRSUFFIX=""
fi
-# Support OpenCASCADE, if installed
-occ=""
-# Not supported until version 3.5.6
-#ls -l /var/log/packages/OpenCASCADE* 2>/dev/null 1>/dev/null
-#[ $? -eq 0 ] && occ="-DOPENCASCADE_INCLUDE_DIR=/opt/OpenCASCADE/inc -DOPENCASCADE_LIBRARY_TYPE=Shared"
-
set -e
rm -rf $PKG
@@ -69,15 +63,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# 20220215 bkw: asio is an optional, auto-detected dependency. Our
-# version of asio is either too new or too old for this. Note
-# that this is Asio (the network library for C++), not
-# ASIO (the Windows low-latency audio API) nor wineasio, nor
-# /usr/include/boost/asio.hpp, whatever that even is. I don't see a
-# way to disable asio support via a cmake variable, so it has to be
-# surgery. Applying this patch disables the RestHttpDevice plugin,
-# hope that's OK.
-patch -p1 < $CWD/disable_asio.diff
+# If installed, ignore asio & OpenCASCADE
+# whose current versions at SBo cause build failure
+patch -p0 < $CWD/no-asio-occ.diff
mkdir -p build
cd build
@@ -87,7 +75,6 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_POSTFIX=$LIBDIRSUFFIX \
-DCMAKE_BUILD_TYPE=Release \
- $occ \
-DBUILD_OSG_EXAMPLES=ON \
make
diff --git a/libraries/OpenSceneGraph/README b/libraries/OpenSceneGraph/README
index 84a7dc336c..3741e35868 100644
--- a/libraries/OpenSceneGraph/README
+++ b/libraries/OpenSceneGraph/README
@@ -11,7 +11,7 @@ Plugins will be automatically generated using the following optional
SBo packages if they are detected at build time:
collada-dom, dcmtk, fltk, fox-toolkit, gdal, gtkglext, libgta,
- libLAS, nvidia-texture-tools, OpenCASCADE, wxGTK3
+ libLAS, nvidia-texture-tools, wxGTK3
These plugins offer significant additional functionality and are
recommended for building a fully featured OpenSceneGraph. However,
diff --git a/libraries/OpenSceneGraph/disable_asio.diff b/libraries/OpenSceneGraph/disable_asio.diff
deleted file mode 100644
index 95f74b7316..0000000000
--- a/libraries/OpenSceneGraph/disable_asio.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt OpenSceneGraph-OpenSceneGraph-3.6.5.patched/CMakeLists.txt
---- OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt 2020-01-31 06:03:07.000000000 -0500
-+++ OpenSceneGraph-OpenSceneGraph-3.6.5.patched/CMakeLists.txt 2022-02-15 01:01:02.259927943 -0500
-@@ -763,9 +763,6 @@
- FIND_PACKAGE(GtkGl)
- FIND_PACKAGE(DirectInput)
- FIND_PACKAGE(NVTT)
-- IF (NOT WIN32)
-- FIND_PACKAGE(Asio)
-- ENDIF()
- FIND_PACKAGE(ZeroConf)
-
- FIND_PACKAGE(LIBLAS)
diff --git a/libraries/OpenSceneGraph/no-asio-occ.diff b/libraries/OpenSceneGraph/no-asio-occ.diff
new file mode 100644
index 0000000000..7f27a4b3f6
--- /dev/null
+++ b/libraries/OpenSceneGraph/no-asio-occ.diff
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2020-01-31 21:03:07.000000000 +1000
++++ CMakeLists.txt 2023-06-02 12:11:26.082000000 +1000
+@@ -743,7 +743,6 @@
+ FIND_PACKAGE(Inventor)
+ FIND_PACKAGE(Jasper)
+ FIND_PACKAGE(OpenEXR)
+- FIND_PACKAGE(OpenCascade)
+ FIND_PACKAGE(COLLADA)
+ FIND_PACKAGE(FBX)
+ FIND_PACKAGE(ZLIB)
+@@ -763,9 +762,6 @@
+ FIND_PACKAGE(GtkGl)
+ FIND_PACKAGE(DirectInput)
+ FIND_PACKAGE(NVTT)
+- IF (NOT WIN32)
+- FIND_PACKAGE(Asio)
+- ENDIF()
+ FIND_PACKAGE(ZeroConf)
+
+ FIND_PACKAGE(LIBLAS)