summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author alkos3332010-05-11 20:00:47 +0200
committer Robby Workman2010-05-11 20:00:47 +0200
commit0fec11f79e7d88f4f0c050c613f686f2031f30a1 (patch)
tree75f4c030b5e97992a1acd9be9fa9402265648af3 /libraries
parent89d66ec8ac6eae887552ae1c99f5907e7edd6a61 (diff)
downloadslackbuilds-0fec11f79e7d88f4f0c050c613f686f2031f30a1.tar.gz
libraries/goffice: Added to 12.0 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/goffice/README1
-rw-r--r--libraries/goffice/goffice.SlackBuild81
-rw-r--r--libraries/goffice/goffice.info8
-rw-r--r--libraries/goffice/gtkdoc-rebase.patch61
-rw-r--r--libraries/goffice/slack-desc19
5 files changed, 170 insertions, 0 deletions
diff --git a/libraries/goffice/README b/libraries/goffice/README
new file mode 100644
index 0000000000..1678137a54
--- /dev/null
+++ b/libraries/goffice/README
@@ -0,0 +1 @@
+GOffice -- A glib/gtk set of document centric objects and utilities
diff --git a/libraries/goffice/goffice.SlackBuild b/libraries/goffice/goffice.SlackBuild
new file mode 100644
index 0000000000..ccde43f7d1
--- /dev/null
+++ b/libraries/goffice/goffice.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# Slackware build script for goffice
+
+# Copyright (c) 2007-2008 Alex Lysenka <me@alkos333.net>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=goffice
+VERSION=0.6.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# http://bugzilla.gnome.org/show_bug.cgi?id=506506#c2
+patch -p1 < $CWD/gtkdoc-rebase.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+
+make
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS BUGS COPYING ChangeLog INSTALL MAINTAINERS NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 644 {} \;
+( cd $PKG/usr/doc/$PRGNAM-$VERSION
+ ln -s /usr/share/gtk-doc/html/goffice html
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/goffice/goffice.info b/libraries/goffice/goffice.info
new file mode 100644
index 0000000000..1af04e8fc8
--- /dev/null
+++ b/libraries/goffice/goffice.info
@@ -0,0 +1,8 @@
+PRGNAM="goffice"
+VERSION="0.6.1"
+HOMEPAGE="http://ftp.gnome.org/pub/GNOME/sources/goffice/"
+DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/goffice/0.6/goffice-0.6.1.tar.bz2"
+MD5SUM="faa72fc615f34b4da8c72d06420f5260"
+MAINTAINER="alkos333"
+EMAIL="me@alkos333.net"
+APPROVED="rworkman"
diff --git a/libraries/goffice/gtkdoc-rebase.patch b/libraries/goffice/gtkdoc-rebase.patch
new file mode 100644
index 0000000000..42ac02ac0f
--- /dev/null
+++ b/libraries/goffice/gtkdoc-rebase.patch
@@ -0,0 +1,61 @@
+diff -ru goffice-0.6.1/docs/reference/Makefile.in goffice-0.6.1/docs/reference/Makefile.in
+--- goffice-0.6.1/docs/reference/Makefile.in 2007-12-20 11:11:28.000000000 +0000
++++ goffice-0.6.1/docs/reference/Makefile.in 2008-01-04 18:33:52.000000000 +0000
+@@ -288,10 +288,10 @@
+ expand_content_files =
+ GTKDOC_CFLAGS = -I$(top_srcdir) -I$(top_builddir) $(GOFFICE_CFLAGS)
+ GTKDOC_LIBS = $(top_builddir)/goffice/libgoffice-@GOFFICE_API_VER@.la $(GOFFICE_LIBS)
+-@GTK_DOC_USE_LIBTOOL_FALSE@GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-@GTK_DOC_USE_LIBTOOL_TRUE@GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-@GTK_DOC_USE_LIBTOOL_FALSE@GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
+-@GTK_DOC_USE_LIBTOOL_TRUE@GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
++@GTK_DOC_USE_LIBTOOL_FALSE@GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CFLAGS) $(CFLAGS)
++@GTK_DOC_USE_LIBTOOL_TRUE@GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CFLAGS) $(CFLAGS)
++@GTK_DOC_USE_LIBTOOL_FALSE@GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS)
++@GTK_DOC_USE_LIBTOOL_TRUE@GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS)
+
+ # We set GPATH here; this gives us semantics for GNU make
+ # which are more like other make's VPATH, when it comes to
+@@ -588,8 +588,9 @@
+ done; \
+ echo '-- Installing $(srcdir)/html/index.sgml' ; \
+ $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
+- which gtkdoc-rebase >/dev/null && \
+- gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++ if test `which gtkdoc-rebase` != ""; then \
++ gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++ fi \
+ fi
+
+ uninstall-local:
+diff -ru goffice-0.6.1/gtk-doc.make goffice-0.6.1/gtk-doc.make
+--- goffice-0.6.1/gtk-doc.make 2007-12-20 11:11:23.000000000 +0000
++++ goffice-0.6.1/gtk-doc.make 2008-01-04 18:33:48.000000000 +0000
+@@ -5,11 +5,11 @@
+ ####################################
+
+ if GTK_DOC_USE_LIBTOOL
+-GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
++GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CFLAGS) $(CFLAGS)
++GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS)
+ else
+-GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
++GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CFLAGS) $(CFLAGS)
++GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS)
+ endif
+
+ # We set GPATH here; this gives us semantics for GNU make
+@@ -139,8 +139,9 @@
+ done; \
+ echo '-- Installing $(srcdir)/html/index.sgml' ; \
+ $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
+- which gtkdoc-rebase >/dev/null && \
+- gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++ if test `which gtkdoc-rebase` != ""; then \
++ gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++ fi \
+ fi
+
+
diff --git a/libraries/goffice/slack-desc b/libraries/goffice/slack-desc
new file mode 100644
index 0000000000..229762b8e3
--- /dev/null
+++ b/libraries/goffice/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+goffice: GOffice (gtk office programs)
+goffice:
+goffice: GOffice is a glib/gtk set of document centric
+goffice: objects and utilities.
+goffice:
+goffice: Homepage: http://ftp.gnome.org/pub/GNOME/sources/goffice/
+goffice:
+goffice:
+goffice:
+goffice:
+goffice: