summaryrefslogtreecommitdiffstats
path: root/libraries/sord
diff options
context:
space:
mode:
author Matteo Bernardini2023-06-25 19:47:37 +0200
committer Willy Sudiarto Raharjo2023-07-02 18:21:27 +0200
commite192330f9445758e757057368e3d873e6344798c (patch)
tree7c70fd5c6197c62639e90b181d8a88b476720cd2 /libraries/sord
parentfdd96f52faeae769f7be3a0bf327e426d5ee287f (diff)
downloadslackbuilds-e192330f9445758e757057368e3d873e6344798c.tar.gz
libraries/sord: Updated for version 0.16.14, switch to meson.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/sord')
-rw-r--r--libraries/sord/sord.SlackBuild40
-rw-r--r--libraries/sord/sord.info6
2 files changed, 26 insertions, 20 deletions
diff --git a/libraries/sord/sord.SlackBuild b/libraries/sord/sord.SlackBuild
index d63b319472..980863b2cd 100644
--- a/libraries/sord/sord.SlackBuild
+++ b/libraries/sord/sord.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for sord
# Copyright 2012-2016 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2020-2021 Matteo Bernardini, Pisa, Italy
+# Copyright 2020-2023 Matteo Bernardini, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sord
-VERSION=${VERSION:-0.16.8}
+VERSION=${VERSION:-0.16.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,7 +71,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -80,19 +80,25 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./waf configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --configdir=/etc \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION
-
-./waf
-
-./waf install \
- --destdir=$PKG
+sed -i doc/meson.build -e "s|^docdir.*|docdir = '/usr/doc/'|" \
+ -e "s|docdir\ /\ versioned_name|docdir / '$PRGNAM-$VERSION'|"
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -100,7 +106,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING INSTALL NEWS README* \
+cp -a AUTHORS COPYING NEWS README* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/sord/sord.info b/libraries/sord/sord.info
index 7403ab0d74..99015074e1 100644
--- a/libraries/sord/sord.info
+++ b/libraries/sord/sord.info
@@ -1,8 +1,8 @@
PRGNAM="sord"
-VERSION="0.16.8"
+VERSION="0.16.14"
HOMEPAGE="http://drobilla.net/software/sord/"
-DOWNLOAD="http://download.drobilla.net/sord-0.16.8.tar.bz2"
-MD5SUM="c54d8e7e2714b4e6280b58b5ecfc2e1d"
+DOWNLOAD="http://download.drobilla.net/sord-0.16.14.tar.xz"
+MD5SUM="73ed5c03c43ef3cc62558c6826b15fa4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="serd"