summaryrefslogtreecommitdiffstats
path: root/libraries/reportlab
diff options
context:
space:
mode:
author LukenShiro2022-11-05 14:52:39 +0100
committer Willy Sudiarto Raharjo2022-11-05 15:15:14 +0100
commit2393cf3dbeec1246535369759ea2e2d8747ac17f (patch)
treee4a2406158a257350a7f3fb7b5e96b006ee09055 /libraries/reportlab
parentbe9ebe8e506d116711bf4e9db7473253a222e092 (diff)
downloadslackbuilds-2393cf3dbeec1246535369759ea2e2d8747ac17f.tar.gz
libraries/reportlab: Removed (renamed python2-reportlab).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/reportlab')
-rw-r--r--libraries/reportlab/README23
-rw-r--r--libraries/reportlab/reportlab.SlackBuild125
-rw-r--r--libraries/reportlab/reportlab.info12
-rw-r--r--libraries/reportlab/slack-desc19
4 files changed, 0 insertions, 179 deletions
diff --git a/libraries/reportlab/README b/libraries/reportlab/README
deleted file mode 100644
index 43391124d9..0000000000
--- a/libraries/reportlab/README
+++ /dev/null
@@ -1,23 +0,0 @@
-The ReportLab Open Source PDF library is a proven industry-strength
-python-based PDF generating solution, suitable for web publishers,
-developers or creative design professionals who need to quickly and
-easily create or automate complex (even data-driven) documents.
-It is released by ReportLab Inc., under BSD license.
-
-It includes binary extensions (previously available separately)
-_rl_accel and renderPM
-
-It has the following features:
-- create professional portable documents
-- real document layout engine (Platypus)
-- flowable objects (paragraphs headlines tables images graphics etc)
-- arbitrary Type-1 fonts
-- bitmap images, vector graphics
-- library of reusable primitive shapes
-- extensible widget library
-- layered architecture
-- includes simple demos and more complex tools
-- allows for any data sources
-- strong community support
-- platform-independent
-- includes PythonPoint - PDF Presentation Tool
diff --git a/libraries/reportlab/reportlab.SlackBuild b/libraries/reportlab/reportlab.SlackBuild
deleted file mode 100644
index 303ed0ff7e..0000000000
--- a/libraries/reportlab/reportlab.SlackBuild
+++ /dev/null
@@ -1,125 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for reportlab
-
-# Copyright 2007-2015 LukenShiro, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by SlackBuilds.org
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=reportlab
-VERSION=${VERSION:-3.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
-# directory for python packages
-PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
-
-DOCFILES="CHANGES.md LICENSE.txt README.txt INSTALL.txt docs/*.pdf"
-OTHERPYFILES="demos tools tests"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Unzip T1 font curves
-cd src/reportlab/fonts/
-unzip $CWD/pfbfer-20070710.zip
-cd -
-
-# Generate pdf documentation
-( cd docs
- # workaround due to dependency loop if reportlab isn't previously installed
- PYTHONPATH=$PYTHONPATH:$TMP/$PRGNAM-$VERSION/src/ python genAll.py
-)
-
-# Move demos, tests and tools directories into python package's home
-# and remove duplicated file
-mkdir -p $PKG/$PYTHONDIR/$PRGNAM/
-mv $OTHERPYFILES $PKG/$PYTHONDIR/$PRGNAM
-rm -f $PKG/$PYTHONDIR/$PRGNAM/tools/docco/*.pdf
-
-# Fix some fonts search paths
-sed -i \
- -e "s|usr/share/fonts/truetype|usr/share/fonts/TTF|" \
- -e "s|usr/local/Acrobat9|opt/Adobe/Reader9|" \
- -e "s|%(HOME)s/fonts|%(HOME)s/.fonts|" \
- src/reportlab/rl_config.py || exit 1
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Move documentation .pdf files and text files to avoid file duplication in
-# python directory
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/reportlab/reportlab.info b/libraries/reportlab/reportlab.info
deleted file mode 100644
index bc7cbad8b9..0000000000
--- a/libraries/reportlab/reportlab.info
+++ /dev/null
@@ -1,12 +0,0 @@
-PRGNAM="reportlab"
-VERSION="3.2.0"
-HOMEPAGE="https://bitbucket.org/rptlab/reportlab/overview"
-DOWNLOAD="https://pypi.python.org/packages/source/r/reportlab/reportlab-3.2.0.tar.gz \
- http://www.reportlab.com/ftp/pfbfer-20070710.zip"
-MD5SUM="79d059e797c557aed4b40c68dd6c7eae \
- 35d20e26490cb2a8646fab6276ac6a4c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-pillow"
-MAINTAINER="LukenShiro"
-EMAIL="lukenshiro@ngi.it"
diff --git a/libraries/reportlab/slack-desc b/libraries/reportlab/slack-desc
deleted file mode 100644
index 129269eed8..0000000000
--- a/libraries/reportlab/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-reportlab: reportlab (PDF generation toolkit using python)
-reportlab:
-reportlab: The ReportLab Open Source PDF library is a proven industry-strength
-reportlab: PDF generating solution, suitable for web publishers, developers
-reportlab: or creative design professionals who need to quickly and easily
-reportlab: create or automate complex (even data-driven) documents.
-reportlab: It is released by ReportLab Inc., under BSD license.
-reportlab:
-reportlab:
-reportlab:
-reportlab: