summaryrefslogtreecommitdiffstats
path: root/libraries/pychm
diff options
context:
space:
mode:
author João Felipe Santos2010-05-12 23:31:07 +0200
committer Robby Workman2010-05-12 23:31:07 +0200
commit0eda190f4e451ddef4c208488a0d204a3653b6d5 (patch)
tree85c4c09296723ebb3a0c77e0c566ac3d7e6ee6b8 /libraries/pychm
parent156e587b271c4aa118dfa66b6af9000a5a5fd2ca (diff)
downloadslackbuilds-0eda190f4e451ddef4c208488a0d204a3653b6d5.tar.gz
libraries/pychm: Added to 12.2 repository
Diffstat (limited to 'libraries/pychm')
-rw-r--r--libraries/pychm/README6
-rw-r--r--libraries/pychm/pychm.SlackBuild71
-rw-r--r--libraries/pychm/pychm.info8
-rw-r--r--libraries/pychm/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/libraries/pychm/README b/libraries/pychm/README
new file mode 100644
index 0000000000..e585e00bbd
--- /dev/null
+++ b/libraries/pychm/README
@@ -0,0 +1,6 @@
+PyCHM is a package that provides bindings for Jed Wing's CHMLIB
+library. The chm package contains four modules, namely chm.chm,
+chm.chmlib, chm.extra and chm._chmlib. chm.chmlib is a low level
+wrapper module around the API provided by the C library chmlib.
+
+PyCHM requires chmlib (available on SlackBuilds.org).
diff --git a/libraries/pychm/pychm.SlackBuild b/libraries/pychm/pychm.SlackBuild
new file mode 100644
index 0000000000..98e779c22a
--- /dev/null
+++ b/libraries/pychm/pychm.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for PyCHM
+
+# Written by João Felipe Santos (joao.eel@gmail.com)
+
+# Copyright (c) 2009 João Felipe Santos
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+PRGNAM=pychm
+VERSION=${VERSION:-0.8.4}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog NEWS PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pychm/pychm.info b/libraries/pychm/pychm.info
new file mode 100644
index 0000000000..9fe94e5f71
--- /dev/null
+++ b/libraries/pychm/pychm.info
@@ -0,0 +1,8 @@
+PRGNAM="pychm"
+VERSION="0.8.4"
+HOMEPAGE="http://gnochm.sourceforge.net/pychm.html"
+DOWNLOAD="http://downloads.sourceforge.net/gnochm/pychm-0.8.4.tar.gz"
+MD5SUM="ff7f0baf94290c44263a1618e7e6a116"
+MAINTAINER="João Felipe Santos"
+EMAIL="joao.eel[at]gmail.com"
+APPROVED="rworkman"
diff --git a/libraries/pychm/slack-desc b/libraries/pychm/slack-desc
new file mode 100644
index 0000000000..ce8923d0e3
--- /dev/null
+++ b/libraries/pychm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pychm: PyCHM (Python bindings for CHMLIB)
+pychm: PyCHM is a package that provides bindings for Jed Wing's CHMLIB
+pychm: library. The chm package contains four modules, namely chm.chm,
+pychm: chm.chmlib, chm.extra and chm._chmlib. chm.chmlib is a low level
+pychm: wrapper module around the API provided by the C library chmlib.
+pychm:
+pychm: Homepage: http://gnochm.sourceforge.net/pychm.html
+pychm:
+pychm:
+pychm:
+pychm: