summaryrefslogtreecommitdiffstats
path: root/libraries/libinklevel/libinklevel.SlackBuild
diff options
context:
space:
mode:
author Robby Workman2010-05-11 19:45:16 +0200
committer Michiel van Wessem2010-05-11 19:45:16 +0200
commit510d59f47f777e982412f7b88fa8286ddd950785 (patch)
tree5e14b421dca572714fa61d62033eb1ed4ed1a262 /libraries/libinklevel/libinklevel.SlackBuild
parent66d5bcb5b2baa03c93eab852968f2618bc4e18b7 (diff)
downloadslackbuilds-510d59f47f777e982412f7b88fa8286ddd950785.tar.gz
libraries/libinklevel: Updated for version 0.7.2
Diffstat (limited to 'libraries/libinklevel/libinklevel.SlackBuild')
-rw-r--r--libraries/libinklevel/libinklevel.SlackBuild39
1 files changed, 25 insertions, 14 deletions
diff --git a/libraries/libinklevel/libinklevel.SlackBuild b/libraries/libinklevel/libinklevel.SlackBuild
index 931f07dc7e..c8e63f1a72 100644
--- a/libraries/libinklevel/libinklevel.SlackBuild
+++ b/libraries/libinklevel/libinklevel.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for libinklevel
-# Copyright 2006 Robby Workman (http://rlworkman.net)
+# Copyright 2006-2008 Robby Workman (http://rlworkman.net)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,33 +22,44 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Modified by the SlackBuilds.org project
-
PRGNAM=libinklevel
-VERSION=0.6.5
+VERSION=0.7.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-march=i686 -mtune=i686"
+fi
+
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
-cd $PRGNAM
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-# Don't try to set ownership of installed files; we'll take care of that
-# in the build script
-patch -p0 < $CWD/Makefile.diff || exit 1
+# Apply a small patch to the default Makefile to respect additional CFLAGS
+# Sent upstream 20070105 --rworkman
+patch -p1 < $CWD/libinklevel-0.7.2-Makefile.diff
-make || exit 1
-make install DESTDIR=$PKG/usr || exit 1
+CFLAGS="$SLKCFLAGS" make
+make install PREFIX=/usr DESTDIR=$PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
@@ -56,7 +67,7 @@ make install DESTDIR=$PKG/usr || exit 1
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING CHANGELOG README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install