summaryrefslogtreecommitdiffstats
path: root/libraries/hamlib
diff options
context:
space:
mode:
author Howard Pepper2010-06-28 16:42:07 +0200
committer dsomero2010-06-28 16:42:07 +0200
commit18c64c99899a30273a431fd4e4c50d64534ad8d9 (patch)
treebfa3e4c510be3b93f32cf1316a01b1d08b49bc14 /libraries/hamlib
parent8925c8b3ba8424c745983ac3f84dc3b8cd628c03 (diff)
downloadslackbuilds-18c64c99899a30273a431fd4e4c50d64534ad8d9.tar.gz
libraries/hamlib: Added (ham radio control libraries)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/hamlib')
-rw-r--r--libraries/hamlib/README5
-rw-r--r--libraries/hamlib/hamlib.SlackBuild103
-rw-r--r--libraries/hamlib/hamlib.info10
-rw-r--r--libraries/hamlib/slack-desc19
4 files changed, 137 insertions, 0 deletions
diff --git a/libraries/hamlib/README b/libraries/hamlib/README
new file mode 100644
index 0000000000..1531e42b0d
--- /dev/null
+++ b/libraries/hamlib/README
@@ -0,0 +1,5 @@
+hamlib (The ham radio control libraries)
+
+A development effort to provide a consistent interface for
+programmers wanting to incorporate radio controls in their
+programs.
diff --git a/libraries/hamlib/hamlib.SlackBuild b/libraries/hamlib/hamlib.SlackBuild
new file mode 100644
index 0000000000..0dbbfe3889
--- /dev/null
+++ b/libraries/hamlib/hamlib.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# SlackBuild script for hamlib.
+#
+# Copyright 2010 Howard Pepper <h_pepper {at} bellsouth [dot] net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hamlib
+VERSION=1.2.11
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="AUTHORS COPYING COPYING.LIB ChangeLog INSTALL LICENSE NEWS PLAN
+ README README.betatester README.developer THANKS TODO"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --enable-shared
+
+# Fix linking when --libdir=/usr/lib64
+sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || exit
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# No manpages are installed
+rm -rf $PKG/usr/man
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/hamlib/hamlib.info b/libraries/hamlib/hamlib.info
new file mode 100644
index 0000000000..a94a561185
--- /dev/null
+++ b/libraries/hamlib/hamlib.info
@@ -0,0 +1,10 @@
+PRGNAM="hamlib"
+VERSION="1.2.11"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/hamlib/index.php?title=Main_Page"
+DOWNLOAD="http://downloads.sourceforge.net/project/hamlib/hamlib/1.2.11/hamlib-1.2.11.tar.gz"
+MD5SUM="1070bba54fb1fb1d538bda6605c07a6c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Howard Pepper"
+EMAIL="h_pepper <at> bellsouth {dot} net"
+APPROVED="dsomero"
diff --git a/libraries/hamlib/slack-desc b/libraries/hamlib/slack-desc
new file mode 100644
index 0000000000..813e0e3688
--- /dev/null
+++ b/libraries/hamlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+hamlib: hamlib (The ham radio control libraries)
+hamlib:
+hamlib: A development effort to provide a consistent interface for
+hamlib: programmers wanting to incorporate radio controls in their
+hamlib: programs.
+hamlib:
+hamlib: Homepage: http://www.hamlib.org
+hamlib:
+hamlib:
+hamlib:
+hamlib: