summaryrefslogtreecommitdiffstats
path: root/libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch
diff options
context:
space:
mode:
author Larry Hajali2016-08-22 01:14:58 +0200
committer David Spencer2016-08-28 01:22:59 +0200
commit1214131e1dff07f74462ae23a8ed3544cb6849ea (patch)
tree40a83803010fcd6dc858db530485c8d3d43eba59 /libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch
parent91be75add67bd9071446aa6a77f0f99699ce9690 (diff)
downloadslackbuilds-1214131e1dff07f74462ae23a8ed3544cb6849ea.tar.gz
libraries/grantlee-qt5: Added (template engine written in Qt5).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch')
-rw-r--r--libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch b/libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch
new file mode 100644
index 0000000000..8788469924
--- /dev/null
+++ b/libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch
@@ -0,0 +1,40 @@
+diff -up grantlee-5.1.0/CMakeLists.txt.orig grantlee-5.1.0/CMakeLists.txt
+--- grantlee-5.1.0/CMakeLists.txt.orig 2016-04-19 01:33:17.000000000 -0500
++++ grantlee-5.1.0/CMakeLists.txt 2016-04-19 06:44:06.371122149 -0500
+@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
+ set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
+ set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
+ set( BIN_INSTALL_DIR bin )
+-set( INCLUDE_INSTALL_DIR include )
++set( INCLUDE_INSTALL_DIR include/Grantlee5 )
+ set( DATA_INSTALL_DIR share/apps )
+
+ # set up RPATH/install_name_dir
+diff -up grantlee-5.1.0/templates/lib/CMakeLists.txt.orig grantlee-5.1.0/templates/lib/CMakeLists.txt
+--- grantlee-5.1.0/templates/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
++++ grantlee-5.1.0/templates/lib/CMakeLists.txt 2016-04-19 06:44:55.763336264 -0500
+@@ -107,6 +107,10 @@ if (Qt5Script_FOUND)
+
+ target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
+ target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
++ target_include_directories(Grantlee_Templates
++ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
++ )
++
+ target_link_libraries(Grantlee_Templates
+ LINK_PRIVATE Qt5::Script
+ )
+diff -up grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig grantlee-5.1.0/textdocument/lib/CMakeLists.txt
+--- grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
++++ grantlee-5.1.0/textdocument/lib/CMakeLists.txt 2016-04-19 06:45:56.268598553 -0500
+@@ -43,6 +43,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Stud
+ endforeach()
+ endif()
+
++target_include_directories(Grantlee_TextDocument
++ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
++)
++
+ target_link_libraries(Grantlee_TextDocument
+ LINK_PUBLIC Qt5::Gui
+ )