summaryrefslogtreecommitdiffstats
path: root/libraries/fltk
diff options
context:
space:
mode:
author dsomero2012-09-02 14:51:42 +0200
committer dsomero2012-09-02 16:34:41 +0200
commitb76395f3995a0733ef2e87078c816cb0d6e41028 (patch)
tree5ac0bdff38b0694963408babe9ebfc83c042ab8b /libraries/fltk
parentfd8e9ddecf41da64e9eecdfda27abf6a8f25d3b4 (diff)
downloadslackbuilds-b76395f3995a0733ef2e87078c816cb0d6e41028.tar.gz
libraries/fltk: Patched to fix underlinking.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/fltk')
-rw-r--r--libraries/fltk/fltk-1.1.10-pkgconfig_xft.patch21
-rw-r--r--libraries/fltk/fltk-1.1.x-r5750-undefined.patch11
-rw-r--r--libraries/fltk/fltk.SlackBuild4
3 files changed, 36 insertions, 0 deletions
diff --git a/libraries/fltk/fltk-1.1.10-pkgconfig_xft.patch b/libraries/fltk/fltk-1.1.10-pkgconfig_xft.patch
new file mode 100644
index 0000000000..b8cb33bcde
--- /dev/null
+++ b/libraries/fltk/fltk-1.1.10-pkgconfig_xft.patch
@@ -0,0 +1,21 @@
+diff -up fltk-1.1.10/configure.pkgconfig_xft fltk-1.1.10/configure
+--- fltk-1.1.10/configure.pkgconfig_xft 2010-02-14 14:03:17.730616944 -0600
++++ fltk-1.1.10/configure 2010-02-14 14:05:05.369368026 -0600
+@@ -12080,7 +12080,7 @@ if test "${ac_cv_lib_Xft_XftDrawCreate+s
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lXft $LIBS"
++LIBS="`pkg-config --libs fontconfig xft` $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -12140,7 +12140,7 @@ if test $ac_cv_lib_Xft_XftDrawCreate = y
+ #define USE_XFT 1
+ _ACEOF
+
+- LIBS="-lXft $LIBS"
++ LIBS="`pkg-config fontconfig xft --libs` $LIBS"
+ fi
+
+ fi
diff --git a/libraries/fltk/fltk-1.1.x-r5750-undefined.patch b/libraries/fltk/fltk-1.1.x-r5750-undefined.patch
new file mode 100644
index 0000000000..8f51c95cdb
--- /dev/null
+++ b/libraries/fltk/fltk-1.1.x-r5750-undefined.patch
@@ -0,0 +1,11 @@
+--- fltk-1.1.x-r5750/src/Makefile.undefined 2007-02-10 08:31:12.000000000 -0600
++++ fltk-1.1.x-r5750/src/Makefile 2007-04-05 07:51:31.000000000 -0500
+@@ -282,7 +282,7 @@
+
+ libfltk_gl.so.1.1: $(GLOBJECTS) libfltk.so.1.1
+ echo $(DSOCOMMAND) $@ ...
+- $(DSOCOMMAND) $@ $(GLOBJECTS) -L. -lfltk
++ $(DSOCOMMAND) $@ $(GLOBJECTS) -L. $(GLDLIBS) -lfltk
+ $(RM) libfltk_gl.so
+ $(LN) libfltk_gl.so.1.1 libfltk_gl.so
+
diff --git a/libraries/fltk/fltk.SlackBuild b/libraries/fltk/fltk.SlackBuild
index aa3c06d2e0..69b18f7310 100644
--- a/libraries/fltk/fltk.SlackBuild
+++ b/libraries/fltk/fltk.SlackBuild
@@ -69,6 +69,10 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# Fix underlinking.
+patch -p1 -i $CWD/fltk-1.1.10-pkgconfig_xft.patch
+patch -p1 -i $CWD/fltk-1.1.x-r5750-undefined.patch
+
# Fix linking when --libdir=/usr/lib64
sed -i \
-e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \