summaryrefslogtreecommitdiffstats
path: root/libraries/decorator
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2017-04-09 04:36:20 +0200
committer Willy Sudiarto Raharjo2017-04-09 04:40:21 +0200
commit9e2a149a6a37dcfe957f1dab3accf25c242bd675 (patch)
tree3767206a0d2fbdf7b353b978ea354807ac5770bc /libraries/decorator
parent93aa00f16e7dcc561a0b158a845a489198774a5c (diff)
downloadslackbuilds-9e2a149a6a37dcfe957f1dab3accf25c242bd675.tar.gz
python/decorator: Updated for version 4.0.11 (moved from libraries).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/decorator')
-rw-r--r--libraries/decorator/README4
-rw-r--r--libraries/decorator/decorator.SlackBuild68
-rw-r--r--libraries/decorator/decorator.info10
-rw-r--r--libraries/decorator/slack-desc19
4 files changed, 0 insertions, 101 deletions
diff --git a/libraries/decorator/README b/libraries/decorator/README
deleted file mode 100644
index d1d2a840af..0000000000
--- a/libraries/decorator/README
+++ /dev/null
@@ -1,4 +0,0 @@
-The aim of the decorator module it to simplify the usage of decorators
-for the average programmer, and to popularize decorators usage giving
-examples of useful decorators, such as memoize, tracing,
-redirecting_stdout, locked, etc.
diff --git a/libraries/decorator/decorator.SlackBuild b/libraries/decorator/decorator.SlackBuild
deleted file mode 100644
index 8545f3b70c..0000000000
--- a/libraries/decorator/decorator.SlackBuild
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for decorator
-
-# Copyright 2013 Mikko Värri, Finland
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=decorator
-VERSION=${VERSION:-3.4.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt documentation* $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/decorator/decorator.info b/libraries/decorator/decorator.info
deleted file mode 100644
index dcd028f0a9..0000000000
--- a/libraries/decorator/decorator.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="decorator"
-VERSION="3.4.0"
-HOMEPAGE="http://pypi.python.org/pypi/decorator"
-DOWNLOAD="http://pypi.python.org/packages/source/d/decorator/decorator-3.4.0.tar.gz"
-MD5SUM="1e8756f719d746e2fc0dd28b41251356"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mikko Värri"
-EMAIL="vmj@linuxbox.fi"
diff --git a/libraries/decorator/slack-desc b/libraries/decorator/slack-desc
deleted file mode 100644
index 24dc979f50..0000000000
--- a/libraries/decorator/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-decorator: decorator (The decorator Python module)
-decorator:
-decorator: The aim of the decorator module it to simplify the usage of
-decorator: decorators for the average programmer, and to popularize decorators
-decorator: usage giving examples of useful decorators, such as memoize, tracing,
-decorator: redirecting_stdout, locked, etcetera.
-decorator:
-decorator: http://www.phyast.pitt.edu/~micheles/python/documentation.html
-decorator:
-decorator:
-decorator: