summaryrefslogtreecommitdiffstats
path: root/libraries/Nevow
diff options
context:
space:
mode:
author dsomero2010-05-20 02:00:23 +0200
committer David Somero2010-05-21 06:18:40 +0200
commit41d80201300398e27bf6e7108ad8651dfadd35a4 (patch)
tree1680d5b59a31a319f38ead3f915042f580848379 /libraries/Nevow
parent37ec84fa0c8ccf42bf5378fdc754b8fa62e80e0e (diff)
downloadslackbuilds-41d80201300398e27bf6e7108ad8651dfadd35a4.tar.gz
libraries/Nevow: Removed (download link broken)
Diffstat (limited to 'libraries/Nevow')
-rwxr-xr-xlibraries/Nevow/Nevow.SlackBuild87
-rw-r--r--libraries/Nevow/Nevow.info10
-rw-r--r--libraries/Nevow/README14
-rw-r--r--libraries/Nevow/slack-desc19
4 files changed, 0 insertions, 130 deletions
diff --git a/libraries/Nevow/Nevow.SlackBuild b/libraries/Nevow/Nevow.SlackBuild
deleted file mode 100755
index 935db01479..0000000000
--- a/libraries/Nevow/Nevow.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Nevow.
-
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Nevow
-VERSION=${VERSION:-0.10.0}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="LICENSE README"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" \
- -e "current ar archive" | grep ELF | cut -f 1 -d : | xargs \
- strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages
-mv $PKG/usr/twisted $PKG/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages
-
-mkdir -p $PKG/usr/man/man1
-mv $PKG/usr/doc/man/* $PKG/usr/man/man1
-gzip -9 $PKG/usr/man/man1/*
-rm -rf $PKG/usr/doc/man
-
-mkdir $PKG/usr/DOCS ; mv $PKG/usr/doc/* $PKG/usr/DOCS
-mv $PKG/usr/DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/Nevow/Nevow.info b/libraries/Nevow/Nevow.info
deleted file mode 100644
index c186eb37a8..0000000000
--- a/libraries/Nevow/Nevow.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Nevow"
-VERSION="0.10.0"
-HOMEPAGE="http://divmod.org/trac/wiki/DivmodNevow"
-DOWNLOAD="http://divmod.org/trac/attachment/wiki/SoftwareReleases/Nevow-0.10.0.tar.gz?format=raw"
-MD5SUM="66dda2ad88f42dea05911add15f4d1b2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Marco Bonetti"
-EMAIL="sid77@slackware.it"
-APPROVED="rworkman"
diff --git a/libraries/Nevow/README b/libraries/Nevow/README
deleted file mode 100644
index dcee73bdea..0000000000
--- a/libraries/Nevow/README
+++ /dev/null
@@ -1,14 +0,0 @@
-Pronounced as the French "nouveau", or "noo-voh", Nevow is a web application
-construction kit written in Python. It is designed to allow the programmer to
-express as much of the view logic as desired in Python, and includes a pure
-Python XML expression syntax named stan to facilitate this. However it also
-provides rich support for designer-edited templates, using a very small XML
-attribute language to provide bi-directional template manipulation capability.
-
-Nevow also includes formless, a declarative syntax for specifying the types of
-method parameters and exposing these methods to the web. Forms can be rendered
-automatically, and form posts will be validated and input coerced, rendering
-error pages if appropriate. Once a form post has validated successfully, the
-method will be called with the coerced values.
-
-This requires pysetuptools, python-twisted, and zope.interface.
diff --git a/libraries/Nevow/slack-desc b/libraries/Nevow/slack-desc
deleted file mode 100644
index a9c7460624..0000000000
--- a/libraries/Nevow/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler----------------------------------------------------|
-Nevow: Nevow (web application construction kit)
-Nevow:
-Nevow: Nevow is designed to allow the programmer to express as much of the
-Nevow: view logic as desired in Python, and includes a pure Python XML
-Nevow: expression syntax named stan to facilitate this. However it also
-Nevow: provides rich support for designer-edited templates, using a very
-Nevow: small XML attribute language to provide bi-directional template
-Nevow: manipulation capability.
-Nevow:
-Nevow: http://divmod.org/trac/wiki/DivmodNevow
-Nevow: