summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Alex Lysenka2010-05-11 19:44:54 +0200
committer Michiel van Wessem2010-05-11 19:44:54 +0200
commite65a5a197e323a98dc1eb29e8641684add62601a (patch)
tree3eb86c1c12fe9e71da2b557ff8e0696d48a61dd8 /graphics
parenta09cdc240ca5eff593ba68659ec1b3b92f2143d8 (diff)
downloadslackbuilds-e65a5a197e323a98dc1eb29e8641684add62601a.tar.gz
graphics/vbetool: Updated for version 0.7
Diffstat (limited to 'graphics')
-rw-r--r--graphics/vbetool/README2
-rw-r--r--graphics/vbetool/slack-desc1
-rw-r--r--graphics/vbetool/vbetool-pciutils.patch48
-rw-r--r--graphics/vbetool/vbetool.SlackBuild41
4 files changed, 85 insertions, 7 deletions
diff --git a/graphics/vbetool/README b/graphics/vbetool/README
index 69821cc301..31cf0e5900 100644
--- a/graphics/vbetool/README
+++ b/graphics/vbetool/README
@@ -3,5 +3,3 @@ it is able to alter DPMS states, save/restore video card state, and
attempt to initialize the video card from scratch. It exists primarily
in order to increase the chances of successfully recovering video state
after an ACPI S3 suspend.
-
-Homepage: http://www.srcf.ucam.org/~mjg59/vbetool/
diff --git a/graphics/vbetool/slack-desc b/graphics/vbetool/slack-desc
index 9e155878d1..8ce1bf97e7 100644
--- a/graphics/vbetool/slack-desc
+++ b/graphics/vbetool/slack-desc
@@ -9,3 +9,4 @@ vbetool: recovering video state after an ACPI S3 suspend.
vbetool:
vbetool: Homepage: http://www.srcf.ucam.org/~mjg59/vbetool/
vbetool:
+vbetool:
diff --git a/graphics/vbetool/vbetool-pciutils.patch b/graphics/vbetool/vbetool-pciutils.patch
new file mode 100644
index 0000000000..bd89507810
--- /dev/null
+++ b/graphics/vbetool/vbetool-pciutils.patch
@@ -0,0 +1,48 @@
+diff -Nru /tmp/Kr0L01zv32/vbetool-0.7/Makefile.am /tmp/dmaQa97eLk/vbetool-0.7/Makefile.am
+--- /tmp/Kr0L01zv32/vbetool-0.7/Makefile.am 2006-07-26 03:21:31.000000000 +0200
++++ /tmp/dmaQa97eLk/vbetool-0.7/Makefile.am 2006-11-27 03:37:31.000000000 +0100
+@@ -23,4 +23,4 @@
+ $(RM) Makefile.in aclocal.m4 config.h.in stamp-h.in configure
+
+ AM_CFLAGS = -g -Wall -pedantic -std=gnu99
+-AM_LDFLAGS =
++AM_LDFLAGS = -lz
+diff -Nru /tmp/Kr0L01zv32/vbetool-0.7/Makefile.in /tmp/dmaQa97eLk/vbetool-0.7/Makefile.in
+--- /tmp/Kr0L01zv32/vbetool-0.7/Makefile.in 2006-07-26 03:26:30.000000000 +0200
++++ /tmp/dmaQa97eLk/vbetool-0.7/Makefile.in 2006-11-27 03:37:55.000000000 +0100
+@@ -182,7 +182,7 @@
+ noinst_HEADERS = include/lrmi.h vbetool.h
+ EXTRA_DIST = vbetool.1 LRMI
+ AM_CFLAGS = -g -Wall -pedantic -std=gnu99
+-AM_LDFLAGS =
++AM_LDFLAGS = -lz
+ all: all-recursive
+
+ .SUFFIXES:
+diff -Nru /tmp/Kr0L01zv32/vbetool-0.7/debian/changelog /tmp/dmaQa97eLk/vbetool-0.7/debian/changelog
+--- /tmp/Kr0L01zv32/vbetool-0.7/debian/changelog 2006-07-26 03:29:16.000000000 +0200
++++ /tmp/dmaQa97eLk/vbetool-0.7/debian/changelog 2006-11-27 03:44:03.000000000 +0100
+@@ -1,3 +1,11 @@
++vbetool (0.7-1.1) unstable; urgency=low
++
++ * Non-maintainer upload.
++ * Add zlib1g-dev to Build-Depends and -lz to LDFLAGS, as needed by newer
++ pciutils (closes: #396844).
++
++ -- Julien Cristau <julien.cristau@ens-lyon.org> Mon, 27 Nov 2006 03:43:37 +0100
++
+ vbetool (0.7-1) unstable; urgency=low
+
+ * Add copyright information. Closes: #375159
+diff -Nru /tmp/Kr0L01zv32/vbetool-0.7/debian/control /tmp/dmaQa97eLk/vbetool-0.7/debian/control
+--- /tmp/Kr0L01zv32/vbetool-0.7/debian/control 2005-11-23 03:53:59.000000000 +0100
++++ /tmp/dmaQa97eLk/vbetool-0.7/debian/control 2006-11-27 03:43:23.000000000 +0100
+@@ -2,7 +2,7 @@
+ Section: utils
+ Priority: optional
+ Maintainer: Matthew Garrett <mjg59@srcf.ucam.org>
+-Build-Depends: debhelper (>= 4.0.0), pciutils-dev
++Build-Depends: debhelper (>= 4.0.0), pciutils-dev, zlib1g-dev
+ Standards-Version: 3.6.1
+
+ Package: vbetool
diff --git a/graphics/vbetool/vbetool.SlackBuild b/graphics/vbetool/vbetool.SlackBuild
index 4267df38fe..77d87f2e83 100644
--- a/graphics/vbetool/vbetool.SlackBuild
+++ b/graphics/vbetool/vbetool.SlackBuild
@@ -1,9 +1,38 @@
#!/bin/sh
-# Build script for vbetool
-# Written by Alex Lysenka <me@alkos333.net>
+# Slackware build script for Amaya
+# Copyright (c) 2007 , Written by Alex Lysenka <me@alkos333.net>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above
+# copyright notice, this list of conditions and the following disclaimer
+# in the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of the {company} nor the names of its
+# contributors may be used to endorse or promote products derived from
+# this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by the SlackBuilds.org project
+# Patch for Slackware 12.0 added by Wade Nelson <hollywoodb@fastmail.fm>
+
set -e
PRGNAM=vbetool
@@ -31,12 +60,14 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+patch -p4 < $CWD/$PRGNAM-pciutils.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAG="$SLKCFLAGS" \
./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --mandir=/usr/man
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --mandir=/usr/man
make || exit 1
make install-strip DESTDIR=$PKG || exit 1