summaryrefslogtreecommitdiffstats
path: root/graphics/pygifme
diff options
context:
space:
mode:
author B. Watson2022-02-27 08:09:36 +0100
committer Robby Workman2022-02-28 05:27:51 +0100
commit2c8e4206ef3cdfe9796cb72284268f46da29a2f4 (patch)
treedf120162cef8e18ac680c03b5625e3780e4f5054 /graphics/pygifme
parent2647bd03cce5eadac338b1cd4a1d9dc48d7eec06 (diff)
downloadslackbuilds-2c8e4206ef3cdfe9796cb72284268f46da29a2f4.tar.gz
graphics/pygifme: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'graphics/pygifme')
-rw-r--r--graphics/pygifme/pygifme.SlackBuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/graphics/pygifme/pygifme.SlackBuild b/graphics/pygifme/pygifme.SlackBuild
index c0f1a14a14..731a4d6525 100644
--- a/graphics/pygifme/pygifme.SlackBuild
+++ b/graphics/pygifme/pygifme.SlackBuild
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220222 bkw: Modified by SlackBuilds.org, BUILD=2: fix build on 15.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pygifme
VERSION=${VERSION:-0.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,17 +74,23 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+# 20220227 bkw: uhhh...
+# AttributeError: module 'platform' has no attribute 'dist'
+# ...this is just a print(), it doesn't *do* anything.
+sed -i "/print.*'Distribution:'/d" setup.py
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+python3 setup.py install --root=$PKG
rm -rf $PKG/usr/share
+# 20220227 bkw: we don't need a shell script for this...
+rm -f $PKG/usr/bin/$PRGNAM
+ln -s $PRGNAM.py $PKG/usr/bin/$PRGNAM
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild