summaryrefslogtreecommitdiffstats
path: root/graphics/openimageio/openimageio.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini2018-08-11 08:22:49 +0200
committer Matteo Bernardini2018-08-11 08:22:49 +0200
commit5b9e2bacbba98d29e840b18893dd5b5f07e4e256 (patch)
tree13f6929744b6579f61d56d2983cf04c686198db9 /graphics/openimageio/openimageio.SlackBuild
parent4b6783ab8163804672754dd5c659308957e9133e (diff)
downloadslackbuilds-5b9e2bacbba98d29e840b18893dd5b5f07e4e256.tar.gz
20180811.1 global branch merge.current-20180811.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/openimageio/openimageio.SlackBuild')
-rw-r--r--graphics/openimageio/openimageio.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/openimageio/openimageio.SlackBuild b/graphics/openimageio/openimageio.SlackBuild
index 450403a92c..a65053d5bc 100644
--- a/graphics/openimageio/openimageio.SlackBuild
+++ b/graphics/openimageio/openimageio.SlackBuild
@@ -77,14 +77,17 @@ find -L . \
# Remove bundled pugixml
#rm -f src/include/OpenImageIO/pugi*
-# save this for GCC 7.0
-#sed -i "s|std=c++11|std=c++11 -Wno-error=maybe-uninitialized -Wno-error=format-truncation -Wno-error=noexcept-type -faligned-new|" CMakeLists.txt
+# newer compilers are stricter
+ADD_FLAGS="-Wno-error=maybe-uninitialized -Wno-error=format-truncation -Wno-error=noexcept-type -faligned-new -Wno-error=stringop-truncation -Wno-error=sizeof-pointer-memaccess -Wno-error=class-memaccess"
+
+# needed for the newer boost
+sed -i "s|python-py|python|" src/python/CMakeLists.txt
mkdir -p build
cd build
cmake ../ \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11 $ADD_FLAGS" \
-DOPENJPEG_INCLUDE_DIR="/usr/include/openmj2-2.1" \
-DOPENJPEG_OPENJPEG_LIBRARIES="openmj2" \
-DCMAKE_BUILD_TYPE=Release \