summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author ArTourter2023-10-17 01:45:29 +0200
committer Willy Sudiarto Raharjo2023-10-21 12:20:14 +0200
commitce135ebdbab74f46d202d91e687646588da87c9b (patch)
tree65f84f53d48d226d7fd5a2c2576e8c353f7d0b72 /gis
parent1a05970a7b5420faa39dbe506582b46a37904f2f (diff)
downloadslackbuilds-ce135ebdbab74f46d202d91e687646588da87c9b.tar.gz
gis/python3-cartopy: Updated for version 0.22.0.
Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/python3-cartopy/python3-cartopy.SlackBuild21
-rw-r--r--gis/python3-cartopy/python3-cartopy.info8
2 files changed, 18 insertions, 11 deletions
diff --git a/gis/python3-cartopy/python3-cartopy.SlackBuild b/gis/python3-cartopy/python3-cartopy.SlackBuild
index af6c9cb95c..54e9139051 100644
--- a/gis/python3-cartopy/python3-cartopy.SlackBuild
+++ b/gis/python3-cartopy/python3-cartopy.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-cartopy
# Copyright 2014-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2021-2023 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-cartopy
-VERSION=${VERSION:-0.21.1}
+VERSION=${VERSION:-0.22.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,12 +77,19 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -perm /111 -o \! -perm 755 -o -exec chmod 755 {} + -o \
+ \! -perm /111 -o \! -perm 644 -o -exec chmod 644 {} +
-python3 setup.py install --root=$PKG
+# Fixing numpy dependency check in pyproject.toml:
+# oldest-supported-numpy has a strict check and doesn't support newer version
+# so we replace it. The alternative is to add --skip-dependency-check to tbe
+# build line but this is not deemed optimal.
+sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
+
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/gis/python3-cartopy/python3-cartopy.info b/gis/python3-cartopy/python3-cartopy.info
index 7d9796d37e..19dbf3eaed 100644
--- a/gis/python3-cartopy/python3-cartopy.info
+++ b/gis/python3-cartopy/python3-cartopy.info
@@ -1,10 +1,10 @@
PRGNAM="python3-cartopy"
-VERSION="0.21.1"
+VERSION="0.22.0"
HOMEPAGE="https://scitools.org.uk/cartopy/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/C/Cartopy/Cartopy-0.21.1.tar.gz"
-MD5SUM="efd693d5367c62d10e25dc9a0392d1cb"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/C/Cartopy/Cartopy-0.22.0.tar.gz"
+MD5SUM="1a96bec92d02a0f9c95fa6364cb0767d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gdal python3-matplotlib python3-pyproj python3-pyshp python3-scipy python3-shapely"
+REQUIRES="gdal python3-matplotlib python3-pyproj python3-pyshp python3-scipy python3-shapely python3-setuptools-scm-opt"
MAINTAINER="ArTourter"
EMAIL="artourter@gmail.com"