summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson2020-10-27 21:51:52 +0100
committer Willy Sudiarto Raharjo2020-10-31 05:15:41 +0100
commit884f8376d3c2dd0542a3e5761ea1e631f746ceab (patch)
treeb93c7c9cb0de2d5ecc90eab181d758b0ac244e40 /games
parent21f9fb48c6729df23ecc17e429ec9bc4ba194aee (diff)
downloadslackbuilds-884f8376d3c2dd0542a3e5761ea1e631f746ceab.tar.gz
games/gzdoom: Updated for version 4.4.2.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/gzdoom/README2
-rw-r--r--games/gzdoom/doinst.sh1
-rw-r--r--games/gzdoom/gzdoom.SlackBuild53
-rw-r--r--games/gzdoom/gzdoom.info8
-rw-r--r--games/gzdoom/window_title_version.diff35
5 files changed, 40 insertions, 59 deletions
diff --git a/games/gzdoom/README b/games/gzdoom/README
index 7755b41bfe..2bee38c3af 100644
--- a/games/gzdoom/README
+++ b/games/gzdoom/README
@@ -1,3 +1,5 @@
+gzdoom (OpenGL port of DOOM)
+
Enhanced OpenGL port of the official DOOM source code that also supports
Heretic, Hexen, and Strife.
diff --git a/games/gzdoom/doinst.sh b/games/gzdoom/doinst.sh
index 4a25de5e6f..65c7e2eeb9 100644
--- a/games/gzdoom/doinst.sh
+++ b/games/gzdoom/doinst.sh
@@ -7,4 +7,3 @@ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
fi
fi
-
diff --git a/games/gzdoom/gzdoom.SlackBuild b/games/gzdoom/gzdoom.SlackBuild
index 404ddb1a7d..33b640cdf4 100644
--- a/games/gzdoom/gzdoom.SlackBuild
+++ b/games/gzdoom/gzdoom.SlackBuild
@@ -6,6 +6,11 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20201027 bkw:
+# - Updated for 4.4.2.
+# - Add new zmusic dep.
+# - Use 'make install/strip' now that it's supported.
+# - Use upstream's icon, multiple sizes in /usr/share/icons.
# 20200302 bkw: Updated for 4.3.3.
# 20191201 bkw: Updated for 4.2.4.
# 20181022 bkw: Updated for 3.6.0.
@@ -27,7 +32,7 @@
# supported as "gzdoom-legacy" for those that need them.
PRGNAM=gzdoom
-VERSION=${VERSION:-4.3.3}
+VERSION=${VERSION:-4.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,22 +69,19 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-g$VERSION $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-g$VERSION.tar.gz || \
- tar xvf $CWD/g$VERSION.tar.gz || \
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || \
- tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-g$VERSION.tar.gz
cd $PRGNAM-g$VERSION || cd $PRGNAM-$VERSION
chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# gzdoom in windowed mode wants to display its git tag and hash as part
-# of the window title. For releases this shows up as "<unknown version> 0",
-# which doesn't hurt anything but is ugly.
-# This makes the window title appear as e.g. "GZDOOM 2.1.1 (Aug 3 2016)". The
-# date is the build date.
-patch -p1 < $CWD/window_title_version.diff
-sed -i "/#define *VERSIONSTR/s,GIT_DESCRIPTION,\"$VERSION\"," src/version.h
+# 20201027 bkw: fix the '<unknown version>' in the window title. This
+# used to be done in an uglier way (with a patch that occasionally broke
+# when applied against new gzdooms).
+sed -i '/COMMAND.*UpdateRevision/s,^,# ,' src/CMakeLists.txt
+( echo "#define GIT_DESCRIPTION \"$VERSION\""
+ echo "#define GIT_HASH \"release\""
+ echo "#define GIT_TIME __DATE__" ) > src/gitinfo.h
# This isn't currently used, but was in the past, and will be again I'm sure.
[ -e $CWD/compilefix.$VERSION.diff ] && \
@@ -99,26 +101,39 @@ cd build
cmake \
-DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS -DSHARE_DIR=\\\"/usr/share/games/doom\\\"" \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DSHARE_DIR=\\\"/usr/share/games/doom\\\"" \
+ -DINSTALL_DOCS_PATH=doc/$PRGNAM-$VERSION \
+ -DINSTALL_PATH=games \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DMAN_INSTALL_DIR=/usr/man \
-DCMAKE_BUILD_TYPE=Release ..
make VERBOSE=1
- mkdir -p $PKG/usr/games $PKG/usr/share/games/doom
- install -m0755 -s $PRGNAM $PKG/usr/games/$PRGNAM
- install -m0644 *.pk3 $PKG/usr/share/games/doom/
+ make install/strip DESTDIR=$PKG
cd ..
+if fgrep -q '<unknown' src/gitinfo.h; then
+ echo "*** BREAKAGE: gitinfo.h got regenerated with <unknown version>" 1>&2
+ echo "*** Fix it, or get the maintainer to." 1>&2
+ echo "*** Press ^C to abort or wait 5 seconds for the build to continue" 1>&2
+ sleep 5
+fi
+
# .desktop written for this SlackBuild
mkdir -p $PKG/usr/share/applications
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
-# PNG converted from Windows icon
+# New-school desktop-ey icons.
+for i in 16 22 32 48 64 128 256; do
+ SIZE=${i}x${i}
+ DIR=$PKG/usr/share/icons/hicolor/$SIZE/apps
+ mkdir -p $DIR
+ convert src/posix/zdoom.xpm -resize $SIZE $DIR/$PRGNAM.png
+done
+
+# Old-school windowmanagerish icon.
mkdir -p $PKG/usr/share/pixmaps
-cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+ln -s ../icons/hicolor/64x64/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README_SBo.txt > $PKG/usr/doc/$PRGNAM-$VERSION/README_SBo.txt
diff --git a/games/gzdoom/gzdoom.info b/games/gzdoom/gzdoom.info
index dd9bf6d272..9466f38585 100644
--- a/games/gzdoom/gzdoom.info
+++ b/games/gzdoom/gzdoom.info
@@ -1,10 +1,10 @@
PRGNAM="gzdoom"
-VERSION="4.3.3"
+VERSION="4.4.2"
HOMEPAGE="http://gzdoom.drdteam.org/"
-DOWNLOAD="https://github.com/coelckers/gzdoom/archive/g4.3.3/gzdoom-g4.3.3.tar.gz"
-MD5SUM="96454a55f7ac9fb5a0072e4802728d1e"
+DOWNLOAD="https://github.com/coelckers/gzdoom/archive/g4.4.2/gzdoom-g4.4.2.tar.gz"
+MD5SUM="0c649af6aef89ce60df724bfb64aeec7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="SDL2 OpenAL"
+REQUIRES="SDL2 OpenAL zmusic"
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"
diff --git a/games/gzdoom/window_title_version.diff b/games/gzdoom/window_title_version.diff
deleted file mode 100644
index 253c88207f..0000000000
--- a/games/gzdoom/window_title_version.diff
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -Naur gzdoom-g3.1.0/src/gitinfo.cpp gzdoom-g3.1.0.patched/src/gitinfo.cpp
---- gzdoom-g3.1.0/src/gitinfo.cpp 2017-05-31 06:11:33.000000000 -0400
-+++ gzdoom-g3.1.0.patched/src/gitinfo.cpp 2017-06-10 16:21:51.138003050 -0400
-@@ -39,27 +39,20 @@
-
- const char *GetGitDescription()
- {
-- return GIT_DESCRIPTION;
-+ return VERSIONSTR;
- }
-
- const char *GetGitHash()
- {
-- return GIT_HASH;
-+ return "release";
- }
-
- const char *GetGitTime()
- {
-- return GIT_TIME;
-+ return __DATE__;
- }
-
- const char *GetVersionString()
- {
-- if (GetGitDescription()[0] == '\0')
-- {
-- return VERSIONSTR;
-- }
-- else
-- {
-- return GIT_DESCRIPTION;
-- }
-+ return VERSIONSTR;
- }