summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2017-05-20 21:53:47 +0200
committer Willy Sudiarto Raharjo2017-05-21 10:33:10 +0200
commit167d2a1e76bbf95ba98f3af31b2cdc804b212048 (patch)
tree7b37af4f4d1b1f3d7eef9a484e9ca149332b9377 /games
parente90ce61ca0e9e16756dbd093d7f173e775a32e7c (diff)
downloadslackbuilds-167d2a1e76bbf95ba98f3af31b2cdc804b212048.tar.gz
games/egoboo: Updated for version 2.8.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/egoboo/egoboo.SlackBuild60
-rw-r--r--games/egoboo/egoboo.info8
-rw-r--r--games/egoboo/keyboard_directions.patch.gzbin0 -> 384 bytes
3 files changed, 42 insertions, 26 deletions
diff --git a/games/egoboo/egoboo.SlackBuild b/games/egoboo/egoboo.SlackBuild
index d5ee00e6df..6f7fbdd1dc 100644
--- a/games/egoboo/egoboo.SlackBuild
+++ b/games/egoboo/egoboo.SlackBuild
@@ -6,13 +6,13 @@
# Maintained by Erik Hanson <erik@slackbuilds.org>
PRGNAM=egoboo
-VERSION=${VERSION:-2.7.4}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.8.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -23,8 +23,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
@@ -43,27 +43,45 @@ cd $PRGNAM-$VERSION
find . -type f -exec chmod -x {} \;
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix end-of-line encoding in *.txt, prefix location in wrapper script.
-sed -i 's/\r//g' *.txt doc/*.txt
-sed -i 's|${HOME}/.local|/usr|' game/$PRGNAM.sh
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix whatever this problem is
-sed -i 's/-lGLU/-lGLU -lm/' game/Makefile.unix
+sed -i 's/-lGLU/-lGLU -lm/' src/game/Makefile
+
+sed -i -e 's/\[COLOR_DEPTH\] : "32"/\[COLOR_DEPTH\] : "24"/g' \
+ -e 's/\[Z_DEPTH\] : "32"/\[Z_DEPTH\] : "24"/g' \
+ -e 's/\[OUTPUT_BUFFER_SIZE\] : "2548/\[OUTPUT_BUFFER_SIZE\] : "2048/g' \
+ setup.txt
+
+
+# fix data paths
+sed -i -e 's#egoboo-2.x#egoboo#g' \
+ -e 's#share/games#share#g' \
+ -e 's#etc#share#g' \
+ -e 's#games#bin#g' \
+ src/game/platform/file_linux.c
+
+# fix linking
+sed -i -e 's#-lenet#-lenet -lm#g' src/game/Makefile
+
+# fix keyboard bug
+zcat $CWD/keyboard_directions.patch | patch -p1 --binary
+
+cd src
+make all
+cd ..
-# Compile and install program.
-make -C game -f Makefile.unix OPT="$SLKCFLAGS -Wall" PREFIX=/usr
-make -C game -f Makefile.unix PREFIX=$PKG/usr install
+mkdir -p $PKG/usr/bin
+install -Dm755 src/game/egoboo-2.x $PKG/usr/bin/egoboo
# Copy data.
mkdir -p $PKG/usr/share/$PRGNAM
-cp -rf controls.txt setup.txt basicdat/ modules/ players/ $PKG/usr/share/$PRGNAM/
+cp -rf controls.txt setup.txt basicdat/ modules/ $PKG/usr/share/$PRGNAM/
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Install icon and desktop files
@@ -71,9 +89,7 @@ install -D -m 0644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
install -D -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- *.txt doc/* License.pdf README.Linux \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt doc/*.txt doc/*.pdf license* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/games/egoboo/egoboo.info b/games/egoboo/egoboo.info
index 7ce31957ed..d43d51634d 100644
--- a/games/egoboo/egoboo.info
+++ b/games/egoboo/egoboo.info
@@ -1,10 +1,10 @@
PRGNAM="egoboo"
-VERSION="2.7.4"
+VERSION="2.8.1"
HOMEPAGE="http://egoboo.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/egoboo/egoboo-2.7.4.tar.gz"
-MD5SUM="6df37fea85c4b76beb1b651d73209608"
+DOWNLOAD="http://downloads.sourceforge.net/egoboo/egoboo-2.8.1.tar.gz"
+MD5SUM="e6f3130695d297dcd9fe74e50bd59b68"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="physfs SDL2_image SDL2_mixer SDL2_ttf enet"
MAINTAINER="Erik Hanson"
EMAIL="erik@slackbuilds.org"
diff --git a/games/egoboo/keyboard_directions.patch.gz b/games/egoboo/keyboard_directions.patch.gz
new file mode 100644
index 0000000000..c9deefab36
--- /dev/null
+++ b/games/egoboo/keyboard_directions.patch.gz
Binary files differ