summaryrefslogtreecommitdiffstats
path: root/games/ufoai
diff options
context:
space:
mode:
author B. Watson2017-07-06 22:10:01 +0200
committer Willy Sudiarto Raharjo2017-07-08 02:11:17 +0200
commit5c08643cc15842f29bbc4279f2e735ea5c51bd25 (patch)
tree84a3b10a4f12d6a3122b71a73e975ee825f7af56 /games/ufoai
parent0b93d5c21bfc75e6411e630a30d800fa5a378ae8 (diff)
downloadslackbuilds-5c08643cc15842f29bbc4279f2e735ea5c51bd25.tar.gz
games/ufoai: Fix build on -current.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'games/ufoai')
-rw-r--r--games/ufoai/ufoai.SlackBuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/games/ufoai/ufoai.SlackBuild b/games/ufoai/ufoai.SlackBuild
index f7702a6a60..47acdd7c3b 100644
--- a/games/ufoai/ufoai.SlackBuild
+++ b/games/ufoai/ufoai.SlackBuild
@@ -15,6 +15,14 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20170706 bkw:
+# - fix build on -current
+
+# 20151126 bkw:
+# - fix build on systems that have SDL2 but not SDL2_ttf
+# - add SDL2 environment variable
+# - move binaries to /usr/games
+
# 20140826 bkw:
# - took over maintenance
# - update for 2.5
@@ -24,11 +32,6 @@
# - allow building the radiant editor. I have no idea if it's working
# correctly, since I have no idea how to use it.
-# 20151126 bkw:
-# - fix build on systems that have SDL2 but not SDL2_ttf
-# - add SDL2 environment variable
-# - move binaries to /usr/games
-
PRGNAM=ufoai
VERSION=${VERSION:-2.5}
BUILD=${BUILD:-2}
@@ -91,6 +94,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# 20170706 bkw: fix build with gcc7
+echo 'CXXFLAGS += -Wno-narrowing' >> build/flags.mk
+
[ "${SDL2:-no}" = "no" ] && EXTRAOPT="--disable-sdl2"
CFLAGS="$SLKCFLAGS" \