summaryrefslogtreecommitdiffstats
path: root/games/redeclipse/redeclipse.SlackBuild
diff options
context:
space:
mode:
author Erik Falor2012-12-26 12:39:40 +0100
committer Matteo Bernardini2012-12-26 21:36:48 +0100
commit0353790ff95c3dd4649f3468273fa58205a57891 (patch)
treed59b7ddc345342c77a45c89a5dc48d9dcc7de5d9 /games/redeclipse/redeclipse.SlackBuild
parent1286dd9529c3a3ede9e368e79cc339561ada5446 (diff)
downloadslackbuilds-0353790ff95c3dd4649f3468273fa58205a57891.tar.gz
games/redeclipse: Added (Fast-paced futuristic FPS).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/redeclipse/redeclipse.SlackBuild')
-rw-r--r--games/redeclipse/redeclipse.SlackBuild103
1 files changed, 103 insertions, 0 deletions
diff --git a/games/redeclipse/redeclipse.SlackBuild b/games/redeclipse/redeclipse.SlackBuild
new file mode 100644
index 0000000000..5ea869cdec
--- /dev/null
+++ b/games/redeclipse/redeclipse.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for Red Eclipse
+
+# Copyright 2012 Erik Falor USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=redeclipse
+VERSION=${VERSION:-1.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/${PRGNAM}_${VERSION}_nix_bsd.tar.bz2
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# remove the pre-built binaries
+rm -f bin/* bin64/*
+
+# Compile the application using custom SLKCFLAGS
+(
+ cd src
+ cp ../doc/man/cube2font.1 install/nix
+
+ # Hack makefiles so Red Eclipse is installed into the folders we specify
+ # and to respect SLKCFLAGS
+ sed -e "s,@VERSION@,$VERSION," $CWD/Makefile.patch | patch -b
+
+ make EXTRA_CXXFLAGS="$SLKCFLAGS" all cube2font
+ make DESTDIR=$PKG system-install system-install-cube2font
+)
+
+# Copy program documentation into the package
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/all-licenses.txt doc/cc-by-sa.txt doc/changelog.txt doc/cube2font.txt \
+ doc/license.txt doc/trademark.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+
+# Copy slack-desc and doinst.sh into ./install
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+# Make the package; be sure to leave it in $OUTPUT
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}