summaryrefslogtreecommitdiffstats
path: root/games/neverball/neverball.SlackBuild
diff options
context:
space:
mode:
author Brad Hermanson2012-06-26 03:15:41 +0200
committer dsomero2012-06-26 03:15:41 +0200
commitf89d4c8180611db13ecfc605ca05c5ef049c49fc (patch)
treeff4e33195af8d10d3fd888a2ccd8b18093e9b4ba /games/neverball/neverball.SlackBuild
parent77a8c67fad15556727441816b70f92851f1846c4 (diff)
downloadslackbuilds-f89d4c8180611db13ecfc605ca05c5ef049c49fc.tar.gz
games/neverball: Updated for version 1.5.4.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games/neverball/neverball.SlackBuild')
-rw-r--r--games/neverball/neverball.SlackBuild56
1 files changed, 28 insertions, 28 deletions
diff --git a/games/neverball/neverball.SlackBuild b/games/neverball/neverball.SlackBuild
index ff70ae9a50..aab1d3177e 100644
--- a/games/neverball/neverball.SlackBuild
+++ b/games/neverball/neverball.SlackBuild
@@ -5,6 +5,8 @@
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# All rights reserved.
#
+# Modified by Brad Hermanson <apeitheo@gmail.com>
+#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
@@ -24,16 +26,14 @@
PRGNAM=neverball
BONUS=neverputt
-VERSION=${VERSION:-1.5.1}
+VERSION=${VERSION:-1.5.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -70,35 +70,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Apply base_config.h.diff patch:
-patch -p0 < $CWD/base_config.h.diff || exit 1
+# Patch Makefile to change data directory and to make it compile
+# with appropriate flags
+patch -p1 < $CWD/Makefile.diff || exit 1
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make || exit 1
+make CFLAGS="$SLKCFLAGS" || exit 1
-mkdir -p $PKG/usr/{bin,share/$PRGNAM}
-cp -a mapc $PRGNAM $BONUS $PKG/usr/bin || exit 1
-cp -a data $PKG/usr/share/$PRGNAM || exit 1
+# Fix map permissions that were created by mapc during compile
+find data/ -name '*.sol' -exec chmod 644 {} \;
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Delete the .map files that are no longer required
+find data/ -name '*.map' -exec rm {} \;
-( cd dist
- install -D -m 0644 mapc.1 $PKG/usr/man/man1/mapc.1
- install -D -m 0644 $PRGNAM.6 $PKG/usr/man/man6/$PRGNAM.6
- install -D -m 0644 $BONUS.6 $PKG/usr/man/man6/$BONUS.6
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES COPYING README doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/usr/{bin,share/$PRGNAM}
+cp -a mapc $PRGNAM $BONUS $PKG/usr/bin || exit 1
+cp -a data/ $PKG/usr/share/$PRGNAM || exit 1
( cd dist
for i in $PRGNAM $BONUS ; do
@@ -114,8 +100,22 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
done
cp -a ${PRGNAM}_replay.png $PKG/usr/share/icons/hicolor/48x48/apps/${PRGNAM}_replay.png
cp -a neverlogos.svg $PKG/usr/share/icons/hicolor/scalable/apps/neverlogos.svg
+ install -D -m 0644 mapc.1 $PKG/usr/man/man1/mapc.1
+ install -D -m 0644 $PRGNAM.6 $PKG/usr/man/man6/$PRGNAM.6
+ install -D -m 0644 $BONUS.6 $PKG/usr/man/man6/$BONUS.6
)
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES COPYING README doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh