summaryrefslogtreecommitdiffstats
path: root/games/neverball/Makefile.diff
diff options
context:
space:
mode:
author Brad Hermanson2012-06-26 03:15:41 +0200
committer dsomero2012-06-26 03:15:41 +0200
commitf89d4c8180611db13ecfc605ca05c5ef049c49fc (patch)
treeff4e33195af8d10d3fd888a2ccd8b18093e9b4ba /games/neverball/Makefile.diff
parent77a8c67fad15556727441816b70f92851f1846c4 (diff)
downloadslackbuilds-f89d4c8180611db13ecfc605ca05c5ef049c49fc.tar.gz
games/neverball: Updated for version 1.5.4.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games/neverball/Makefile.diff')
-rw-r--r--games/neverball/Makefile.diff29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/neverball/Makefile.diff b/games/neverball/Makefile.diff
new file mode 100644
index 0000000000..f9cc96f5a7
--- /dev/null
+++ b/games/neverball/Makefile.diff
@@ -0,0 +1,29 @@
+diff -Nur neverball-1.5.4.orig//Makefile neverball-1.5.4/Makefile
+--- neverball-1.5.4.orig//Makefile 2012-06-02 00:19:40.340921775 -0400
++++ neverball-1.5.4/Makefile 2012-06-02 21:54:52.078406763 -0400
+@@ -27,7 +27,7 @@
+ # Paths (packagers might want to set DATADIR and LOCALEDIR)
+
+ USERDIR := .neverball
+-DATADIR := ./data
++DATADIR := /usr/share/neverball/data
+ LOCALEDIR := ./locale
+
+ ifdef MINGW
+@@ -131,14 +131,14 @@
+ OGL_LIBS := -framework OpenGL
+ endif
+
+-BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS)
++BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS) -lm
+
+ ifdef DARWIN
+ BASE_LIBS += -L/opt/local/lib
+ endif
+
+ ALL_LIBS := $(SDL_LIBS) $(BASE_LIBS) $(TILT_LIBS) $(INTL_LIBS) -lSDL_ttf \
+- -lvorbisfile $(OGL_LIBS)
++ -lvorbisfile $(OGL_LIBS) -lX11
+
+ #------------------------------------------------------------------------------
+