summaryrefslogtreecommitdiffstats
path: root/games/maelstrom/install_dirs.diff
diff options
context:
space:
mode:
author B. Watson2010-05-12 23:29:26 +0200
committer David Somero2010-05-12 23:29:26 +0200
commit1a3537baa7360d5394d9dc1feced739581c40447 (patch)
tree87ecf8bb438ec87ea06da7980f0a78dde8489d95 /games/maelstrom/install_dirs.diff
parentfc32ee20694957df640a5960a4a7fd58efca770b (diff)
downloadslackbuilds-1a3537baa7360d5394d9dc1feced739581c40447.tar.gz
games/maelstrom: Added to 12.2 repository
Diffstat (limited to 'games/maelstrom/install_dirs.diff')
-rw-r--r--games/maelstrom/install_dirs.diff35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/maelstrom/install_dirs.diff b/games/maelstrom/install_dirs.diff
new file mode 100644
index 0000000000..08c95405b1
--- /dev/null
+++ b/games/maelstrom/install_dirs.diff
@@ -0,0 +1,35 @@
+diff -Naur Maelstrom-3.0.6/Makefile.in Maelstrom-3.0.6.patched/Makefile.in
+--- Maelstrom-3.0.6/Makefile.in 2002-10-20 00:19:42.000000000 -0400
++++ Maelstrom-3.0.6.patched/Makefile.in 2009-04-14 14:45:59.000000000 -0400
+@@ -431,7 +431,7 @@
+
+ # Special install rule for the game
+ install:
+- make install_gamedata target=@GAME_INSTALLDIR@
++ make install_gamedata target=$(DESTDIR)/@GAME_INSTALLDIR@
+
+ install_gamedata:
+ sh mkinstalldirs $(target)/
+@@ -444,8 +444,8 @@
+ chmod 666 $(target)/Maelstrom-Scores
+
+ install_gamedocs:
+- sh mkinstalldirs $(target)/
+- cp -rv README* COPYING* Docs* $(target)/
++ sh mkinstalldirs $(DESTDIR)/$(target)/
++ cp -rv README* COPYING* Docs* $(DESTDIR)/$(target)/
+
+ # Rule to build tar-gzipped distribution package
+ $(PACKAGE)-$(VERSION).tar.gz: dist
+diff -Naur Maelstrom-3.0.6/configure Maelstrom-3.0.6.patched/configure
+--- Maelstrom-3.0.6/configure 2002-10-19 23:43:07.000000000 -0400
++++ Maelstrom-3.0.6.patched/configure 2009-04-14 14:47:33.000000000 -0400
+@@ -3232,7 +3232,7 @@
+ GAME_INSTALLDIR="\$(prefix)/games/$PACKAGE"
+ ;;
+ *)
+- GAME_INSTALLDIR="\$(prefix)/games/$PACKAGE"
++ GAME_INSTALLDIR="\$(prefix)/share/games/$PACKAGE"
+ ;;
+ esac
+