summaryrefslogtreecommitdiffstats
path: root/games/higan
diff options
context:
space:
mode:
author Gabriel Magno2014-03-13 02:20:42 +0100
committer Erik Hanson2014-03-21 19:01:14 +0100
commit3e626757b35bce68e31ca25883b6dc0c77359787 (patch)
tree68f2e2ef7f6cc49510b1200e162419ba83cc8e80 /games/higan
parent92b93c47140a7ae97c170a3634f6298836a2bc6a (diff)
downloadslackbuilds-3e626757b35bce68e31ca25883b6dc0c77359787.tar.gz
games/higan: Updated for version 094.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/higan')
-rw-r--r--games/higan/README27
-rw-r--r--games/higan/higan-v094.patch (renamed from games/higan/higan-v093.patch)64
-rw-r--r--games/higan/higan.SlackBuild24
-rw-r--r--games/higan/higan.info8
4 files changed, 71 insertions, 52 deletions
diff --git a/games/higan/README b/games/higan/README
index 8d1859956f..912cc6de9b 100644
--- a/games/higan/README
+++ b/games/higan/README
@@ -10,31 +10,38 @@ Famicom (SNES), Game Boy, Game Boy Color and Game Boy Advance.
It also supports the following subsystems: Super Game Boy,
BS-X Satellaview and Sufami Turbo.
-*Options*
+
+* Options *
1) higan has 2 interfaces to choose from. The default is QT
and the other is GTK. If you'd like to choose the GTK interface,
then pass INTERFACE=gtk to the slackbuild.
+INTERFACE=qt|gtk (default: qt)
+
2) There are 3 modes that higan can be built. There can only be one
mode chosen at build time. The 3 modes are accuracy, balanced (default),
and performance. To choose accuracy mode pass PROFILE=accuracy to
the slackbuild. For performance mode pass PROFILE=performance to the
slackbuild.
-*Configuration*
+PROFILE=accuracy|balanced|performance (default: balanced)
+
+3) If you want to have an OpenAL or pulseaudio audio driver option,
+you can build higan to support them by passing OPENAL=yes and
+PULSEAUDIO=yes to the slackbuild, which would require their respective
+packages. By default, these options are disabled.
+
+OPENAL=yes|no (default: no), requires OpenAL
+PULSEAUDIO=yes|no (default: no), requires pulseaudio
+
+
+* Configuration *
The default profile folder (where platform system files, cheats and
shaders are located) is /usr/share/higan. If you want a personalized
profile, store your files in ~/.config/higan/, then higan will use
this folder instead.
-Since the ananke library is also built, you can import your regular
-ROM game files into higan's library using the option "Import Game" in
-the Library menu. When you import a rom file it will be converted into
-higan's format and saved in the Game Library Path specified in the
-Advanced Settings options (Settings -> Configuration -> Advanced).
-After that you can load your game through the correspondent system
-option in the Library menu.
-If you want to use shaders, select OpenGL as the video driver.
+Optional dependencies: OpenAL, pulseaudio
diff --git a/games/higan/higan-v093.patch b/games/higan/higan-v094.patch
index 3e27deea70..2277fee691 100644
--- a/games/higan/higan-v093.patch
+++ b/games/higan/higan-v094.patch
@@ -1,35 +1,41 @@
-diff -ruN higan_v093-source/ananke/Makefile higan_v093-source_MOD/ananke/Makefile
---- higan_v093-source/ananke/Makefile 2013-08-02 17:36:56.000000000 -0300
-+++ higan_v093-source_MOD/ananke/Makefile 2013-09-24 09:42:36.399970000 -0300
-@@ -25,9 +25,9 @@
-
- install: uninstall
- ifeq ($(platform),x)
+diff -ruN higan_v094-source/ananke/Makefile higan_v094-source_MOD/ananke/Makefile
+--- higan_v094-source/ananke/Makefile 2013-12-19 13:10:40.000000000 +0300
++++ higan_v094-source_MOD/ananke/Makefile 2014-03-11 12:04:37.875388819 +0300
+@@ -31,9 +31,9 @@
+ sudo cp libananke.dylib $(path)/libananke.1.dylib
+ sudo ln -s $(path)/libananke.1.dylib $(path)/libananke.dylib
+ else
- if [ ! -d ~/.config/ananke ]; then mkdir ~/.config/ananke; fi
- sudo cp libananke.so $(path)/libananke.so.1
- sudo ln -s $(path)/libananke.so.1 $(path)/libananke.so
-+ mkdir -p $(path)
++ mkdir -p $(path)
+ cp libananke.so $(path)/libananke.so.1
+ ln -s $(path)/libananke.so.1 $(path)/libananke.so
- else ifeq ($(platform),osx)
- if [ ! -d ~/Library/Application\ Support/ananke ]; then mkdir ~/Library/Application\ Support/ananke; fi
- sudo cp libananke.dylib $(path)/libananke.1.dylib
-diff -ruN higan_v093-source/target-ethos/Makefile higan_v093-source_MOD/target-ethos/Makefile
---- higan_v093-source/target-ethos/Makefile 2013-08-16 20:39:20.000000000 -0300
-+++ higan_v093-source_MOD/target-ethos/Makefile 2013-09-24 09:53:39.367766000 -0300
-@@ -16,7 +16,7 @@
- # platform
- ifeq ($(platform),x)
- ruby := video.glx video.xv video.sdl
-- ruby += audio.alsa audio.openal audio.oss audio.pulseaudio audio.pulseaudiosimple audio.ao
-+ ruby += audio.alsa audio.openal audio.oss audio.ao
- ruby += input.sdl input.x
- else ifeq ($(platform),osx)
- ruby := video.cgl
-@@ -86,14 +86,14 @@
+ endif
- install:
- ifeq ($(platform),x)
+ uninstall:
+diff -ruN higan_v094-source/target-ethos/Makefile higan_v094-source_MOD/target-ethos/Makefile
+--- higan_v094-source/target-ethos/Makefile 2014-01-13 08:26:29.000000000 +0300
++++ higan_v094-source_MOD/target-ethos/Makefile 2014-03-11 15:57:18.360490754 +0300
+@@ -24,7 +24,13 @@
+ ruby += input.carbon
+ else ifeq ($(platform),linux)
+ ruby := video.glx video.xv video.xshm video.sdl
+- ruby += audio.alsa audio.openal audio.oss audio.pulseaudio audio.pulseaudiosimple audio.ao
++ ruby += audio.alsa audio.oss audio.ao
++ ifeq ($(with_openal),yes)
++ ruby += audio.openal
++ endif
++ ifeq ($(with_pulseaudio),yes)
++ ruby += audio.pulseaudio audio.pulseaudiosimple
++ endif
+ ruby += input.udev input.sdl input.x
+ else ifeq ($(platform),bsd)
+ ruby := video.glx
+@@ -96,14 +102,14 @@
+ sudo cp data/cheats.bml /Library/Application\ Support/$(name)/cheats.bml
+ sudo chmod -R 777 /Library/Application\ Support/$(name)
+ else
- sudo install -D -m 755 out/$(name) $(DESTDIR)$(prefix)/bin/$(name)
- sudo install -D -m 644 data/$(name).png $(DESTDIR)$(prefix)/share/pixmaps/$(name).png
- sudo install -D -m 644 data/$(name).desktop $(DESTDIR)$(prefix)/share/applications/$(name).desktop
@@ -46,6 +52,6 @@ diff -ruN higan_v093-source/target-ethos/Makefile higan_v093-source_MOD/target-e
+ cp -R profile/* $(DESTDIR)/usr/share/$(name)
+ cp data/cheats.bml $(DESTDIR)/usr/share/$(name)/cheats.bml
+ chmod -R 777 $(DESTDIR)/usr/share/$(name)
- else ifeq ($(platform),osx)
- sudo mkdir -p /Library/Application\ Support/$(name)
- sudo cp -R profile/* /Library/Application\ Support/$(name)
+ endif
+
+ uninstall:
diff --git a/games/higan/higan.SlackBuild b/games/higan/higan.SlackBuild
index 2692f2526a..947516a35c 100644
--- a/games/higan/higan.SlackBuild
+++ b/games/higan/higan.SlackBuild
@@ -26,8 +26,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=higan
-VERSION=${VERSION:-093}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-094}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -74,7 +74,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Apply the patch to allow proper install on Slackware as root
-patch -p1 -i $CWD/higan-v093.patch
+patch -p1 -i $CWD/higan-v094.patch
# Fix building with QT >= 4.8.0.
moc -i -Iphoenix/qt/ -o phoenix/qt/platform.moc phoenix/qt/platform.moc.hpp
@@ -86,25 +86,31 @@ INTERFACE=${INTERFACE:-qt}
# Possible values for PROFILE: accuracy, balanced, and performance.
PROFILE=${PROFILE:-balanced}
+# Options to build with additional audio driver support
+OPENAL=${OPENAL:-no}
+PULSEAUDIO=${PULSEAUDIO:-no}
+
CXXFLAGS="$SLKCFLAGS" \
make \
compiler=g++ \
- cppflags="-std=gnu++11" \
+ cppflags="-std=c++11" \
prefix=/usr \
- platform=x \
+ platform=linux \
+ with_openal="$OPENAL" \
+ with_pulseaudio="$PULSEAUDIO" \
phoenix="$INTERFACE" \
profile="$PROFILE"
-make install DESTDIR=$PKG prefix=/usr platform=x profile=$PROFILE
+make install DESTDIR=$PKG prefix=/usr platform=linux profile=$PROFILE
# Compile ananke (tool to import ROM game files into the higan library).
make -C ananke \
compiler=g++ \
- cppflags="-std=gnu++11" \
- platform=x \
+ cppflags="-std=c++11" \
+ platform=linux \
phoenix="$INTERFACE" \
profile="$PROFILE"
-make -C ananke install path=$PKG/usr/lib${LIBDIRSUFFIX} platform=x
+make -C ananke install path=$PKG/usr/lib${LIBDIRSUFFIX} platform=linux
# Copy shaders
mkdir $PKG/usr/share/higan/Video\ Shaders
diff --git a/games/higan/higan.info b/games/higan/higan.info
index 4d209e94f9..6b47f795ad 100644
--- a/games/higan/higan.info
+++ b/games/higan/higan.info
@@ -1,10 +1,10 @@
PRGNAM="higan"
-VERSION="093"
+VERSION="094"
HOMEPAGE="http://byuu.org/higan/"
-DOWNLOAD="http://byuu.org/files/higan_v093-source.tar.xz"
-MD5SUM="051e794c2f86c185fd51106181a09c58"
+DOWNLOAD="http://byuu.org/files/higan_v094-source.tar.xz"
+MD5SUM="a0e8730f64f0ba666b4282b8145b8c31"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="OpenAL"
+REQUIRES=""
MAINTAINER="Gabriel Magno"
EMAIL="gabrielmagno1@gmail.com"